Bug 56876 - fdisk fails to detect >16 partitions on IDE disk
Summary: fdisk fails to detect >16 partitions on IDE disk
Status: CLOSED DUPLICATE of bug 56244
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.2
Hardware: athlon
OS: Linux
medium
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-29 12:58 UTC by Martin N Dunstan
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-03 20:56:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Martin N Dunstan 2001-11-29 12:58:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
I had a 40Gb IDE disk with 18 partitions
(4 primary with one unused and 14 logical).
I used fdisk to delete partitions 7-11 so
that I could replace them with a single
partition. However, fdisk only showed 16
partitions and considered the last two to
be part of free space on the disk. Note
that this is only a problem with the fdisk
in the installer: /sbin/fdisk is fine.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Partition your IDE disk so that it has
  at least 15 logical partitions.
2.Run the RH 7.2 installer and try fdisk
3.Print the partition table
	

Actual Results:  The extended partition /dev/hda3 was shown
to have the correct size but no partitions
above /dev/hda16 were known. When fdisks
writes the partition table to disk the
hda17 etc partitions are lost. 

Expected Results:  The installer fdisk ought to work exactly
like the /sbin/fdisk that gets installed.
That is, all partitions above hda16 ought
to be visible and mutable.

Additional info:

I've marked this high because unless you
take remedial action you could lose data
in the partitions that fdisk dropped. I
had to finish the install so that I could
use /sbin/fdisk to get the partitions back.
I could not use DiskDruid as I had to
specify the start/end of the partitions
using cylinders not Mb.

Comment 1 Michael Fulbright 2001-12-03 20:55:55 UTC
Brent please reproduce - the fdisk in the installer is exactly the same as
/sbin/fdisk so this is odd.

Comment 2 Elliot Lee 2002-01-03 23:39:23 UTC

*** This bug has been marked as a duplicate of 56244 ***


Note You need to log in before you can comment on or make changes to this bug.