Bug 568788
| Summary: | example sender coredumps when the queue is limited | ||||||||||
|---|---|---|---|---|---|---|---|---|---|---|---|
| Product: | Red Hat Enterprise MRG | Reporter: | Jan Sarenik <jsarenik> | ||||||||
| Component: | qpid-cpp | Assignee: | Andrew Stitcher <astitcher> | ||||||||
| Status: | CLOSED ERRATA | QA Contact: | Jan Sarenik <jsarenik> | ||||||||
| Severity: | high | Docs Contact: | |||||||||
| Priority: | urgent | ||||||||||
| Version: | Development | CC: | gsim | ||||||||
| Target Milestone: | 1.3 | ||||||||||
| Target Release: | --- | ||||||||||
| Hardware: | All | ||||||||||
| OS: | Linux | ||||||||||
| Whiteboard: | |||||||||||
| Fixed In Version: | Doc Type: | Bug Fix | |||||||||
| Doc Text: | Story Points: | --- | |||||||||
| Clone Of: | Environment: | ||||||||||
| Last Closed: | 2010-10-20 11:30:57 UTC | Type: | --- | ||||||||
| Regression: | --- | Mount Type: | --- | ||||||||
| Documentation: | --- | CRM: | |||||||||
| Verified Versions: | Category: | --- | |||||||||
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |||||||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||||||
| Embargoed: | |||||||||||
| Bug Depends On: | |||||||||||
| Bug Blocks: | 505287 | ||||||||||
| Attachments: |
|
||||||||||
|
Description
Jan Sarenik
2010-02-26 16:04:02 UTC
Created attachment 396576 [details]
gdb corefile trace
Store module is not needed for this bug to appear. What's the progress here, please? This bug is blocking another one from being verified. If I can help, let me know because most of the bugs in my list are currently stalled. Might this be a duplicate of bug 580824? I.e. deletion of connection impl before dispatch handle is deactivated in the exceptional cases? Resolved by r935275. Created attachment 416395 [details] Verification tarball containing scripts. See README after extracting the tarball. Verified on RHEL5.5 i386 and x86_64. ------------------------------------------------------- root@mrg-qe-12:~/bz505827# ./runtest redhat-release-5Server-5.5.0.2 i686 qpid-cpp-server-store-0.7.946106-1.el5 qpid-cpp-client-devel-0.7.946106-1.el5 python-qpid-0.7.946106-1.el5 qpid-tools-0.7.946106-4.el5 Compiling... done Configuring queue... ok Running sender, logging to sender.log... ---------- reciever's output follows one two three four five == receiver exited with 0 ---------- sender.log follows 2010-05-25 14:58:02 warning Exception received from broker: resource-limit-exceeded: resource-limit-exceeded: Policy exceeded on test-queue, policy: size: max=104857600, current=19; count: max=5, current=5; type=reject (qpid/broker/QueuePolicy.cpp:85) [caused by 5 \x00:\x00] Failed: resource-limit-exceeded: resource-limit-exceeded: Policy exceeded on test-queue, policy: size: max=104857600, current=19; count: max=5, current=5; type=reject (qpid/broker/QueuePolicy.cpp:85) 2010-05-25 14:58:02 warning Connection closed TEST SUCCESSFUL Verified on RHEL4 i386 and x86_64 with the same package build as above. |