Bug 568790 - /etc/rc.d/rc.sysinit tries to activate RAIDs called "no", "raid", and "sets"
Summary: /etc/rc.d/rc.sysinit tries to activate RAIDs called "no", "raid", and "sets"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 568869
TreeView+ depends on / blocked
 
Reported: 2010-02-26 16:06 UTC by Sven
Modified: 2014-03-17 03:22 UTC (History)
5 users (show)

Fixed In Version: initscripts-9.02.2-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 568869 (view as bug list)
Environment:
Last Closed: 2010-03-20 03:49:26 UTC
Type: ---


Attachments (Terms of Use)

Description Sven 2010-02-26 16:06:04 UTC
Description of problem:
On a system with a "Marvell Technology Group Ltd. MV88SX6041 4-port SATA II PCI-X Controller" but with the disks not configured as RAID, just passed through to the OS as separate drives, the call to dmraid gets a return value it can't handle. It then tries to activate each word in the error message as an array. Without rd_NO_DM added to grub.conf, booting fails.

in rc.sysinit:
...
dmraidsets=$(LC_ALL=C /sbin/dmraid -s -c -i)
if [ "$dmraidsets" != "no raid disks" -a "$dmraidsets" != "no block devices found" ]; then
...

output of "LC_ALL=C /sbin/dmraid -s -c -i":
ERROR: no RAID set found
no raid sets



Version-Release number of selected component (if applicable):
initscripts-9.02.1-1.i686

Additional info:
Output of "LC_ALL=C /sbin/dmraid -s -c -i -vv":
NOTICE: /dev/dm-1: asr     discovering
NOTICE: /dev/dm-1: ddf1    discovering
NOTICE: /dev/dm-1: hpt37x  discovering
NOTICE: /dev/dm-1: hpt45x  discovering
NOTICE: /dev/dm-1: isw     discovering
NOTICE: /dev/dm-1: jmicron discovering
NOTICE: /dev/dm-1: lsi     discovering
NOTICE: /dev/dm-1: nvidia  discovering
NOTICE: /dev/dm-1: pdc     discovering
NOTICE: /dev/dm-1: sil     discovering
NOTICE: /dev/dm-1: via     discovering
NOTICE: /dev/dm-0: asr     discovering
NOTICE: /dev/dm-0: ddf1    discovering
NOTICE: /dev/dm-0: hpt37x  discovering
NOTICE: /dev/dm-0: hpt45x  discovering
NOTICE: /dev/dm-0: isw     discovering
NOTICE: /dev/dm-0: jmicron discovering
NOTICE: /dev/dm-0: lsi     discovering
NOTICE: /dev/dm-0: nvidia  discovering
NOTICE: /dev/dm-0: pdc     discovering
NOTICE: /dev/dm-0: sil     discovering
NOTICE: /dev/dm-0: via     discovering
NOTICE: /dev/sde: asr     discovering
NOTICE: /dev/sde: ddf1    discovering
NOTICE: /dev/sde: hpt37x  discovering
NOTICE: /dev/sde: hpt45x  discovering
NOTICE: /dev/sde: isw     discovering
NOTICE: /dev/sde: jmicron discovering
NOTICE: /dev/sde: lsi     discovering
NOTICE: /dev/sde: nvidia  discovering
NOTICE: /dev/sde: pdc     discovering
NOTICE: /dev/sde: sil     discovering
NOTICE: /dev/sde: via     discovering
NOTICE: /dev/sdd: asr     discovering
NOTICE: /dev/sdd: ddf1    discovering
NOTICE: /dev/sdd: ddf1 metadata discovered
NOTICE: /dev/sdd: hpt37x  discovering
NOTICE: /dev/sdd: hpt45x  discovering
NOTICE: /dev/sdd: isw     discovering
NOTICE: /dev/sdd: jmicron discovering
NOTICE: /dev/sdd: lsi     discovering
NOTICE: /dev/sdd: nvidia  discovering
NOTICE: /dev/sdd: pdc     discovering
NOTICE: /dev/sdd: sil     discovering
NOTICE: /dev/sdd: via     discovering
NOTICE: /dev/sdc: asr     discovering
NOTICE: /dev/sdc: ddf1    discovering
NOTICE: /dev/sdc: ddf1 metadata discovered
NOTICE: /dev/sdc: hpt37x  discovering
NOTICE: /dev/sdc: hpt45x  discovering
NOTICE: /dev/sdc: isw     discovering
NOTICE: /dev/sdc: jmicron discovering
NOTICE: /dev/sdc: lsi     discovering
NOTICE: /dev/sdc: nvidia  discovering
NOTICE: /dev/sdc: pdc     discovering
NOTICE: /dev/sdc: sil     discovering
NOTICE: /dev/sdc: via     discovering
NOTICE: /dev/sdb: asr     discovering
NOTICE: /dev/sdb: ddf1    discovering
NOTICE: /dev/sdb: ddf1 metadata discovered
NOTICE: /dev/sdb: hpt37x  discovering
NOTICE: /dev/sdb: hpt45x  discovering
NOTICE: /dev/sdb: isw     discovering
NOTICE: /dev/sdb: jmicron discovering
NOTICE: /dev/sdb: lsi     discovering
NOTICE: /dev/sdb: nvidia  discovering
NOTICE: /dev/sdb: pdc     discovering
NOTICE: /dev/sdb: sil     discovering
NOTICE: /dev/sdb: via     discovering
NOTICE: /dev/sda: asr     discovering
NOTICE: /dev/sda: ddf1    discovering
NOTICE: /dev/sda: ddf1 metadata discovered
NOTICE: /dev/sda: hpt37x  discovering
NOTICE: /dev/sda: hpt45x  discovering
NOTICE: /dev/sda: isw     discovering
NOTICE: /dev/sda: jmicron discovering
NOTICE: /dev/sda: lsi     discovering
NOTICE: /dev/sda: nvidia  discovering
NOTICE: /dev/sda: pdc     discovering
NOTICE: /dev/sda: sil     discovering
NOTICE: /dev/sda: via     discovering
NOTICE: added /dev/sdd to RAID set ".ddf1_disks"
NOTICE: added /dev/sdc to RAID set ".ddf1_disks"
NOTICE: added /dev/sdb to RAID set ".ddf1_disks"
NOTICE: added /dev/sda to RAID set ".ddf1_disks"
ERROR: no RAID set found
no raid sets

Comment 1 Bill Nottingham 2010-02-26 18:36:15 UTC

*** This bug has been marked as a duplicate of bug 527726 ***

Comment 2 Bill Nottingham 2010-02-26 18:37:21 UTC
Oh, geez, it's *another* random return message.

Comment 3 Bill Nottingham 2010-02-26 19:37:52 UTC
http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=9dd0d96d79b4c3f04161eb9513c8bbcef8aec615

Will be fixed in a future F-12 update, and rawhide.

Comment 4 Fedora Update System 2010-03-03 21:44:25 UTC
initscripts-9.07-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/initscripts-9.07-1.fc13

Comment 5 Fedora Update System 2010-03-04 01:33:18 UTC
initscripts-9.07-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update initscripts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F13/FEDORA-2010-3604

Comment 6 Fedora Update System 2010-03-14 13:39:54 UTC
initscripts-9.08-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update initscripts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/initscripts-9.08-1.fc13

Comment 7 Fedora Update System 2010-03-20 03:49:16 UTC
initscripts-9.08-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2010-04-28 19:03:18 UTC
initscripts-9.02.2-1 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/initscripts-9.02.2-1

Comment 9 Fedora Update System 2010-05-22 01:47:52 UTC
initscripts-9.02.2-1 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.