This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 56880 - Installer panics kernel w/message "kernel panic:VFS:Unable to mount root fs on 09:02"
Installer panics kernel w/message "kernel panic:VFS:Unable to mount root fs o...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-29 09:06 EST by Chip Elmblad
Modified: 2008-08-01 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chip Elmblad 2001-11-29 09:06:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.5 [en]C-COMM 4.5  (WinNT; U)

Description of problem:
During initial install of Red Hat Linux 7.2, system panics at same place in process each attempt. 
System: Ezztouch 27c 1GHZ Notebook Computer, 20GB HDD, DVD-ROM 
Error message:   EXT2-fs: unable to read superblock
                               cramfs: wrong magic 
                               isofs-read-super: bread failed, dev=09:02, iso_blknum=16, block=32
                               kernel panic:VFS:Unable to mount root fs on 09:02

My system is now partitioned as follows:
                                  Partition 0 - starts at Sector 63 (Cyl 0, Hd 1, Sect 1) and ends on Sector
                                  8,819,684 (Cyl 548, Hd 254, Sect 63). Total of 4,307.5 MB. This is an          
                                  unformatted partition.

                                  Partition 1 - starts at Sector 8,819,685 (Cyl 549, Hd 0, Sect 1) and ends on
                                  Sector 38,764,844 (Cyl 2,412, Hd 254, Sect 63). Total of 14,621.7 MB. This 
                                  is a FAT32 partition with Windows 2000 loaded and operational within it. 

                                  Partition 2 - starts at Sector 38,764,845 (Cyl 2,413, Hd 0 Sect 1) and ends on
                                  Sector 39,070,079 (Cyl 2,431, Hd 254, Sect 63). Total of 149 MB. This is       
                                  an unformatted partition. 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot to Red Hat 7.2 Install Disk 1
2.
3.
	

Actual Results:  Boot screen allows entry of boot options (i.e. expert, nofb, etc). No matter which selection is made, system then displays 
two screens of "boot output" until it panics with the message described above. 

Expected Results:  The installer should install the OS

Additional info:

Error message:   EXT2-fs: unable to read superblock
                               cramfs: wrong magic 
                               isofs-read-super: bread failed, dev=09:02, iso_blknum=16, block=32
                               kernel panic:VFS:Unable to mount root fs on 09:02

I have tried booting with all of the listed options on the opening boot screen, as well as with noapic, noathlon and ide=nodma per Red 
Hat 
tech support with the identical panic results. I have also tried creating an EXT2 partition with Partition Magic with the same results as 
above. Nothing gets past this panic message.
Comment 1 Michael Fulbright 2001-12-03 15:54:50 EST
It looks like your CD #1 is bad - did you happen to burn it yourself, or is it a
store bought CD?
Comment 2 Chip Elmblad 2001-12-03 17:06:50 EST
It is a store bought CD. A friend of mine burned a CD from your website and loaded 7.2 successfully on his machine with it - I also tried his CD and 
got the identical panic message as with the store bought CD on my system.
Comment 3 Brent Fox 2001-12-03 23:28:30 EST
Ok, we've verified that the cd's aren't the problem.  Since you are seeing a
kernel panic, I'm changing the component of this bug to the kernel.
Comment 4 Arjan van de Ven 2001-12-04 04:19:39 EST
Can you try adding "mem=xxxM" (where "xxx" is half the amount of memory you have
in megabytes) to prompt on the very very first screen ?
eg "linux mem=256M"
Comment 5 Rory Jaffe 2001-12-21 20:03:11 EST
I am having the same problem. The last few lines read:
RAMDISK: Compressed image found at block 0
crc errorFreeing initrd memory: 2046k freed
EXT2-fs: unable to read superblock
cramfs: wrong magic
isofs_read_super: bread failed, dev=09:02, iso_blknum=16, block=32
Kernel panic: VFS: Unable to mount root fs on 09:02

Running "linux mem=128M" (I have 256M RAM did not help. Same problem.
I have noted on the users group messages that there are a number of people 
encountering this error.
Comment 6 Need Real Name 2002-03-21 18:22:51 EST
I4m have same problem. My computer is an atlhon xp 1700+. Anyone can help us??
Comment 7 Mitch Davis 2002-03-27 08:23:25 EST
I have a friend who is also experiencing this problem.

1. Why is the major:minor device number 09:02?  On my
   computer, that's /dev/md2.  Is the MD stuff really
   involved at this stage?

2. Which major:minor device should the boot loader be
   telling the kernel to use as the cramdisk?

3. My understanding is that ramdisks/initrds are loaded
   into memory by the boot loader, ready for the kernel
   to find at the end of initialization.  If the problem
   is a CD error with the ram disk loopback file, why is
   the kernel showing the iso_read_super CD error, and not
   the boot loader?

Here's my interpretation of the problem:

1. The kernel can't load the root fs because the ramdisk
   magic (and indeed the rest of the ramdisk) is missing.

2. The magic is missing because the boot loader coudn't
   load it, or loaded it in the wrong spot, or the boot
   loader told the kernel the wrong address or device 
   number.

Why there are no errors before this is puzzling.

I think the hard disk partition information is a red
hat^wherring.  I have a suggestion for chipdog@onebox.com:
Remove the cable from your hard disk and try again.  I
believe this will rule out any connection between the
configuration of the hard disk, and the problem.
Comment 8 Need Real Name 2002-03-28 08:12:47 EST
Finally, I resolved the problem. My Motherboard is a Gigabyte 7VTXH, with DUAL 
BIOS. When i upgrade my bios, the bug just disappear.
Comment 9 chase 2002-09-26 20:52:35 EDT
hello i am also getting a message similar to your but mine is 09:00 not 09:02 
i dont have enough experience with red hat to know if this makes a difference 
i did update my bios with no luck in stoping the error message the massage i 
get is below 
Installer panics kernel w/message "kernel panic:VFS:Unable to mount root fs on 
09:00
Comment 10 Bugzilla owner 2004-09-30 11:39:18 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.