Bug 568860 - QtWebKit does not search correct plugin path(s)
QtWebKit does not search correct plugin path(s)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-26 13:48 EST by Mark Williamson
Modified: 2010-07-13 03:43 EDT (History)
4 users (show)

See Also:
Fixed In Version: qt-4.6.3-8.fc12
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 03:39:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark Williamson 2010-02-26 13:48:52 EST
Description of problem:

I'm using an x86_64 system and have not verified whether variations of this problem can occur on other architectures.  I'm running Fedora 12, KDE 4.4, QT 4.6.2.  Recent QT (since around 4.5/4.6, I think?) can load Netscape / Mozilla plugins in QTWebKit but this does not function as expected for me.

QtWebKit does not find all plugins on my system; in particular it does not search /usr/lib64/mozilla/plugins-wrapped/ by default.  Aside from meaning that other wrapped plugins are presumably not found (does it use unwrapped plugins instead, perhaps?  I'm not sure), this is where it would normally find a wrapped version of the 32-bit flash plugin.

As a result, using a release of rekonq compiled from git (see http://gitorious.org/rekonq) I do not have working Flash.  If I set the environment variable QTWEBKIT_PLUGIN_PATH to point to /usr/lib64/mozilla/plugins-wrapped then Flash works under rekonq as expected (modulo some bugs that may well be rekonq-specific).

My suggestion is that, since the plugins-wrapped path is the default mode of operation on 64-bit Fedora, QtWebKit could be patched to support this path by default (which should lead to rekonq and other QtWebKit users working with plugins without further configuration).  Would it perhaps also be worth my raising a bug with upstream also?

Version-Release number of selected component (if applicable):

QT 4.6.2, release 1.fc12

How reproducible:

On a 64-bit box, install a flash-capable version of rekonq (e.g. from git mainline), plus wrapped 32-bit Flash plugin.  Then attempt to browse a Flash site.  I'd expect this to work with Arora and other users of QtWebKit too.

Additional info:

This is where I discovered the environment variable work around I'm currently using:
http://lists.trolltech.com/pipermail/qt-interest/2009-June/008503.html

Suggestions here about adding new plugin paths to QtWebKit although I'm not able to comment on whether they're actually good suggestions!
http://stackoverflow.com/questions/2139983/add-a-new-plugins-path-to-qtwebkit
Comment 1 Kevin Kofler 2010-02-26 14:53:19 EST
Yes, it almost certainly uses the unwrapped plugins.
Comment 2 Rex Dieter 2010-06-18 10:53:16 EDT
cool, looks like it groks,
WebCore/plugins/PluginDatabase.cpp:    String mozPath(getenv("MOZ_PLUGIN_PATH"));
WebCore/plugins/PluginDatabase.cpp:    String qtPath(qgetenv("QTWEBKIT_PLUGIN_PATH").constData());

*maybe* a good global fedora solution is to ensure that MOZ_PLUGIN_PATH is set properly, then this should work everywhere.
Comment 3 Rex Dieter 2010-06-18 11:03:34 EDT
meh, I'll just patch in the wrapped paths, should be upstreamable too.
Comment 4 Rex Dieter 2010-06-18 11:14:22 EDT
* Fri Jun 18 2010 Rex Dieter <rdieter@fedoraproject.org> 4.7.0-0.19.beta1
- revert -no-javascript-jit change, false-alarm (#604003)
- QtWebKit does not search correct plugin path(s) (#568860)
- QtWebKit browsers crash with flash-plugin (rh#605677,webkit#40567)
- drop qt-x11-opensource-src-4.5.0-gcc_hack.patch
Comment 5 Rex Dieter 2010-06-18 11:50:48 EDT
* Fri Jun 18 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.6.3-4
- QtWebKit does not search correct plugin path(s) (#568860)
- QtWebKit browsers crash with flash-plugin (rh#605677,webkit#40567)
Comment 6 Fedora Update System 2010-07-12 08:54:11 EDT
qt-4.6.3-8.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/qt-4.6.3-8.fc13
Comment 7 Fedora Update System 2010-07-12 08:56:15 EDT
qt-4.6.3-8.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/qt-4.6.3-8.fc12
Comment 8 Fedora Update System 2010-07-13 03:38:54 EDT
qt-4.6.3-8.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2010-07-13 03:42:35 EDT
qt-4.6.3-8.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.