Bug 568875 - UI quirk when installing a system with only advanced storage devices
UI quirk when installing a system with only advanced storage devices
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-02-26 14:43 EST by James Laska
Modified: 2013-09-02 02:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: anaconda-13.35-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-22 22:27:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot.png (86.28 KB, image/png)
2010-02-26 14:43 EST, James Laska
no flags Details
Additional log files (/tmp/*log.tgz) (25.13 KB, application/x-gzip)
2010-02-26 14:43 EST, James Laska
no flags Details
/tmp/*log (and screenshot) using anaconda-13.32 + 568875.img (122.00 KB, application/x-gzip)
2010-03-02 08:10 EST, James Laska
no flags Details
/tmp/*log (and screenshot) using anaconda-13.32 + 568875.img #2 (121.96 KB, application/x-gzip)
2010-03-02 16:49 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2010-02-26 14:43:01 EST
Created attachment 396646 [details]
Screenshot.png

Description of problem:

Start the installer on a system with *only* a BIOS raid device.  The 'Basic storage device' screen correctly shows zero basic devices.  However, the [un]select-all check box in the 'Basic storage device' appears to choose a device that's not listed (see attached screenshot).

Version-Release number of selected component (if applicable):
 * anaconda-13.32

How reproducible:


Steps to Reproduce:
1. Boot installer on a system with *only* a BIOS RAID device (dmraid)
2. Select basic storage devices
3. Toggle the 'select-all' field 
  
Actual results:

See screenshot

Expected results:

No basic devices selected if no basic devices are available for selection?
Comment 1 James Laska 2010-02-26 14:43:45 EST
Created attachment 396647 [details]
Additional log files (/tmp/*log.tgz)

-rw-r--r-- root/root     31465 2010-02-26 14:47 tmp/X.log
-rw-r--r-- root/root      4393 2010-02-26 14:47 tmp/anaconda.log
-rw-r--r-- root/root      2083 2010-02-26 14:47 tmp/program.log
-rw-r--r-- root/root      3063 2010-02-26 14:47 tmp/storage.log
-rw-r--r-- root/root     86314 2010-02-26 14:47 tmp/syslog
Comment 2 Chris Lumens 2010-02-26 14:56:20 EST
Probably the same fix as will be required for 516143.
Comment 3 Chris Lumens 2010-03-01 18:44:31 EST
Does updates=http://clumens.fedorapeople.org/568875.img fix this?  I've been completely unable to test it yet so there could be a stupid typo in there.  You know, for when you've got free time and need something else to do...
Comment 4 James Laska 2010-03-02 08:10:03 EST
Created attachment 397319 [details]
/tmp/*log (and screenshot) using anaconda-13.32 + 568875.img

Using the provided updates.img, the reported problem remains.

-rw-r--r-- root/root     40394 2010-03-02 08:16 tmp/X.log
-rw-r--r-- root/root      3388 2010-03-02 08:16 tmp/anaconda.log
-rw-r--r-- root/root      1304 2010-03-02 08:16 tmp/program.log
-rw-r--r-- root/root      2721 2010-03-02 08:16 tmp/storage.log
-rw-r--r-- root/root     76929 2010-03-02 08:16 tmp/syslog
-rw-r--r-- root/root      6635 2010-03-02 08:16 tmp/updates/DeviceSelector.pyc
-rw-r--r-- root/root     25405 2010-03-02 08:16 tmp/updates/filter_gui.pyc
-rw-rw-r-- 500/500       28160 2010-03-01 18:38 tmp/updates/filter_gui.py
-rw-rw-r-- 500/500        7899 2010-03-01 18:38 tmp/updates/DeviceSelector.py
-rw-r--r-- root/root     88768 2010-03-02 08:16 tmp/anaconda-screenshots/screenshot-0000.png
Comment 5 Chris Lumens 2010-03-02 10:53:46 EST
Fixed an obvious problem and tested on a setup with both CCISS and regular drives to verify it only applies to the currently displayed page.  That should be the same fix that takes care of this.

Can you give it another try?
Comment 6 James Laska 2010-03-02 16:49:21 EST
Created attachment 397423 [details]
/tmp/*log (and screenshot) using anaconda-13.32 + 568875.img #2

> Can you give it another try?    

Doesn't appear to be a change, see attached screenshot and log files.
Comment 7 Chris Lumens 2010-03-02 17:11:02 EST
This, of course, is because of a typo in copying the image on over to fedorapeople.org that resulted in you still trying the old stuff.  Once more, if you please.  Sorry for wasting your time.
Comment 8 James Laska 2010-03-03 13:29:09 EST
The provided updates image resolved the reported problem.
Comment 9 James Laska 2010-03-03 14:05:55 EST
Adding to F13Blocker per item#5 on the Final release criteria (https://fedoraproject.org/wiki/Fedora_13_Final_Release_Criteria):

    "The installer must be able to create and install to any workable partition
    layout using any file system offered in a default installer configuration,
    LVM, software, hardware or BIOS RAID, or combination of the above "

While this issue does not prevent installation to BIOS RAID adapters, it does represent a usability problem as most users will instinctively use the 'Basic Storage Devices' screen.
Comment 10 Fedora Update System 2010-03-18 13:22:44 EDT
anaconda-13.35-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.35-1.fc13
Comment 11 Fedora Update System 2010-03-22 22:26:15 EDT
anaconda-13.35-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.