Bug 568919 - [abrt] crash in SwModify::Modify at closing of a document
[abrt] crash in SwModify::Modify at closing of a document
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:1e9506e87e2f9ef478d398c10dc...
:
: 734927 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-26 17:35 EST by learnmarket
Modified: 2011-09-01 06:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-27 06:40:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (53.55 KB, text/plain)
2010-02-26 17:35 EST, learnmarket
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 84159 None None None Never

  None (edit)
Description learnmarket 2010-02-26 17:35:22 EST
abrt 1.0.7 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/openoffice.org3/program/scalc.bin -calc
comment: don't know when that happend
component: openoffice.org
executable: /usr/lib64/openoffice.org3/program/scalc.bin
kernel: 2.6.31.12-174.2.22.fc12.x86_64
package: openoffice.org-calc-1:3.1.1-19.26.fc12
rating: 4
reason: Process /usr/lib64/openoffice.org3/program/scalc.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)
Comment 1 learnmarket 2010-02-26 17:35:27 EST
Created attachment 396693 [details]
File: backtrace
Comment 2 David Tardon 2010-02-27 03:21:52 EST
The crash is on closing of a text document. Do you remember editing such a document? Especially, did you add/remove/modify any character style? Did you have change tracking enabled for that document?
Comment 3 learnmarket 2010-02-27 04:22:15 EST
Hi David,
I remember I was editing the document and when it crashed when trying to close it. The document closed without me noticing the crashing. I only noticed the crashed when the bugzilla alert popped (1 or 2 minutes later). When I tried to open the document later, the system recovered it properly.
I did not modify in any way any character style or changed the tracking for the document.
Sorry I can't be of more help.
Kind regards,
Javier
Comment 4 Caolan McNamara 2010-02-27 06:40:35 EST
I feel that this is likely http://qa.openoffice.org/issues/show_bug.cgi?id=84159

We should rebase SfxItemPool and friends on stl::vector/stl::deque/stl::list or something and remove the USHORT based current ones that sometimes trip up like this.
Comment 5 David Tardon 2011-09-01 06:35:05 EDT
*** Bug 734927 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.