Bug 568920 - Hitting 'Write to disk' in 'CD/DVD Creator' crashes Nautilus
Hitting 'Write to disk' in 'CD/DVD Creator' crashes Nautilus
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: brasero (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-02-26 17:35 EST by Adam Williamson
Modified: 2010-03-11 08:33 EST (History)
5 users (show)

See Also:
Fixed In Version: brasero-2.29.91-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-11 08:33:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stacktrace (5.87 KB, text/plain)
2010-03-03 19:00 EST, Matthias Clasen
no flags Details

  None (edit)
Description Adam Williamson 2010-02-26 17:35:43 EST
This is somewhat complex, but picking the menus package to report against.

F13 Alpha RC4 still contains a 'CD/DVD Creator' link under Applications / System Tools. This opens a Nautilus window at burn:/// . The problem is that this system is no longer functional since Brasero replaced nautilus-cd-burner . You can add files to this 'location', but hitting 'Write to Disc' just closes the window without running anything.

Either the burn:/// location should be hooked up to Brasero somehow, or this menu entry should be suppressed (and possibly also the burn:/// location should be removed from nautilus).

This blocks the "All applications listed under the Applications menu must withstand a basic functionality test and not crash after a few minutes of normal use. They must also have working Help and Help -> About menu items" final release criterion: https://fedoraproject.org/wiki/Fedora_13_Final_Release_Criteria
Comment 1 Matthias Clasen 2010-02-26 18:20:05 EST
> The problem is that
> this system is no longer functional since Brasero replaced nautilus-cd-burner

That is not true. It worked just fine in F-12, with brasero.
If it doesn't now, then that is a bug that needs to be fixed.
Most likely in brasero, moving this bug there for now.
Comment 2 Adam Williamson 2010-02-26 20:23:25 EST
ah, I didn't realize it had worked in f12.

well, I tested just in a KVM with no disc drive, but Brasero runs standalone happily enough. When you click 'Write to Disc', the nautilus window closes and then...nothing else happens.

(trying it on my f13-with-updates-testing desktop is interesting, I get:

Error: DBus error org.freedesktop.DBus.Error.ServiceUnknown: The name org.gtk.vfs.Daemon was not provided by any .service files
Please select another viewer and try again.

looks like possibly another gvfs bug...)
Comment 3 Matthias Clasen 2010-02-26 20:49:13 EST
org.gtk.vfs.Daemon is provided by 

$ rpm -qf /usr/share/dbus-1/services/gvfs-daemon.service 
gvfs-1.5.4-2.fc13.x86_64
Comment 4 Adam Williamson 2010-02-26 21:01:12 EST
yeah, I just realised I hadn't updated to the fixed gvfs on my desktop yet (I tested the fix in a VM).
Comment 5 Bastien Nocera 2010-03-03 14:05:40 EST
So, fixed?
Comment 6 Matthias Clasen 2010-03-03 15:36:45 EST
No. When I brought up the nautilus cd-burner location earlier today, filled it and clicked 'write', nautilus crashed
Comment 7 Adam Williamson 2010-03-03 18:43:39 EST
bastien: no. I should've been more clear. the whole thing about 'my desktop' is just a side note. I experienced this actual issue in a VM, and it's still valid. Hitting 'Write to Disc' with Nautilus open at 'CD/DVD Creator' crashes Nautilus, as Matthias says.

(Also, the 'Write to Disc' button's icon appears to be missing, it shows up as the white sheet of paper with red X).
Comment 8 Adam Williamson 2010-03-03 18:44:49 EST
adjusting summary and reassigning to nautilus, as it seems this should exist but hook into Brasero. and actually work.
Comment 9 Matthias Clasen 2010-03-03 19:00:54 EST
Created attachment 397686 [details]
stacktrace
Comment 10 Matthias Clasen 2010-03-03 19:01:36 EST
crash is in the brasero nautilus extension, in brasero_burn_caps_get_default
Comment 11 Adam Williamson 2010-03-03 19:08:19 EST
doh, sorry for being lazy and not checking the crash. I have terribly important mailing list arguing to do! sigh.
Comment 12 Matthias Clasen 2010-03-03 19:26:45 EST
The g_log in the stacktrace is actually this:

  g_error ("You must call brasero_burn_library_start () before using API from libbrasero-burn");
Comment 13 Fedora Update System 2010-03-03 21:17:36 EST
brasero-2.29.91-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/brasero-2.29.91-2.fc13
Comment 14 Fedora Update System 2010-03-04 22:39:12 EST
brasero-2.29.91-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update brasero'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/brasero-2.29.91-2.fc13
Comment 15 Fedora Update System 2010-03-11 08:32:58 EST
brasero-2.29.91-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.