Bug 568928 - netdump-server appears to be missing scripts
Summary: netdump-server appears to be missing scripts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: netdump-server
Version: el5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Neil Horman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-26 22:59 UTC by David Ritchie
Modified: 2010-04-15 15:45 UTC (History)
2 users (show)

Fixed In Version: netdump-server-0.7.16-22.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-15 15:45:50 UTC


Attachments (Terms of Use)

Description David Ritchie 2010-02-26 22:59:08 UTC
Description of problem: when installing netdump-server-0.7.16-21.el5.x86_64.rpm on a RHEL 5.4 server (new install of netdump)appears to be missing several scripts in /usr/share/doc/netdump-server*/example_scripts.


Version-Release number of selected component (if applicable): 
0.7.16-21.el5.x86_64


How reproducible: easily


Steps to Reproduce:
1. rpm -qlp netdump-server-0.7.16-21.el5.x86_64.rpm 
2. look for netdump-nospace and netdump-crash scripts(see 
   http://www.redhat.com/support/wpapers/redhat/netdump/setup.html, 
     9th paragraph) scripts - shouldn't these in 
     /usr/share/doc/netdump-server*/example_scripts ? (There may be others)

Actual results:
these files are not present

Expected results:
That should be available (without installing a SRC RPM). 

Additional info:

Comment 1 Neil Horman 2010-02-27 01:49:47 UTC
They could be but they don't need to be, they are really meant to be site specific scripts, and they're usually pretty simple, so theres really no much point in including any scripts as such.

Comment 2 David Ritchie 2010-03-01 13:47:33 UTC
The reason I reported bug 568928 as a bug is that there is published documentation pointing  to the presence of these files as installed *examples* in the documentation (i.e. /usr/share/doc) directories that should be present after installation of the netdump-server package. They are not there when the package is installed currently, and it appears that there is no other packages that these example files are installed as a part of
(such as a 'netdump-server-doc' package). Are these files located in the source RPM and not distributed in the binary RPM? The docs are sparse in their discussion of this. So I disagree with the CLOSED/NOTABUG disposition of this bug - the defect as reported impedes use of the RPM as distributed.

Comment 3 Neil Horman 2010-03-01 17:16:50 UTC
It really doesn't impede the use of anything.  I didn't include the example scripts because honestly, they're not worth including.  You could have found them n the old RHEL4 channel if you really wanted them, and you would have seen that they all do the same thing, which is nothing more than firing off an email to an administrator.  I was hoping to have a few less files to carry around, but if they're really that important to you, I suppose these no harm in adding them.

Comment 4 Fedora Update System 2010-03-01 18:12:09 UTC
netdump-server-0.7.16-22.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/netdump-server-0.7.16-22.el5

Comment 5 Fedora Update System 2010-03-02 19:03:52 UTC
netdump-server-0.7.16-22.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/netdump-server-0.7.16-22.el5

Comment 6 Fedora Update System 2010-03-03 00:19:12 UTC
netdump-server-0.7.16-22.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update netdump-server'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2010-2333

Comment 7 Fedora Update System 2010-04-15 15:45:45 UTC
netdump-server-0.7.16-22.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.