This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 56905 - rpm update fails with devfs
rpm update fails with devfs
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: SysVinit (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-29 15:38 EST by Bernie Innocenti
Modified: 2014-03-16 22:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-29 15:38:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernie Innocenti 2001-11-29 15:38:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120

Description of problem:
rpm can't update the package when /dev is a devfs filesystem because
renaming /dev/initctl fails

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. mount devfs in /dev
2. type rpm -U SysVinit-2.79-2.i386.rpm



Actual Results:  output from rpm is:

error: unpacking of archive failed on file /dev/initctl: cpio: rename
failed - Operation not permitted


Additional info:
Comment 1 Bill Nottingham 2002-01-25 02:10:12 EST
If you need to install in a situation where /dev is (essentially) read-only, you
should add devfs to the netsharedpath that RPM will exclude. See
/usr/lib/rpm/macros for details.


Note You need to log in before you can comment on or make changes to this bug.