Bug 569132 - Wacom tablet does not work in Qt
Wacom tablet does not work in Qt
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
12
All Linux
low Severity urgent
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-28 05:38 EST by Lukas Tvrdy
Modified: 2010-03-22 22:24 EDT (History)
9 users (show)

See Also:
Fixed In Version: qt-4.6.2-8.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-22 22:09:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Tvrdy 2010-02-28 05:38:39 EST
Description of problem:
1. Test Qt testing app for tablet /usr/lib/qt4/examples/widgets/tablet/tablet
2. Tablet is not working, does not send the tablet events and you can't paint with pressure or tilt.

Version-Release number of selected component (if applicable):
Qt 4.6.2
X.Org X Server 1.7.4
xorg-x11-drv-wacom-0.10.4-2.fc12.i686

How reproducible:
It does not work at all.

Steps to Reproduce:
1.See description of the problem
  
Actual results:
No tablet support in Qt based apps like Krita, or any KDE app.

Expected results:
Working tablet support

Additional info:
My tablet is Wacom Intuos 3. The pressure works in Gimp, MyPaint.
My xorg.conf is not configured, I depend on automatic detection of hw.

Here is blogreport with discussion about this problem which occurs also in Kubuntu and in Archlinux:
http://lukast.mediablog.sk/log/?p=203
Comment 1 Peter Hutterer 2010-03-01 01:52:52 EST
does the tablet send the right output if you run "xinput --test <device name>"? you can get the device name with xinput --list.

each value printed refers to one of the axes, IIRC it's x, y, pressure, tilt x, tilt y
Comment 2 Lukas Tvrdy 2010-03-01 03:42:39 EST
xinput --test "Wacom Intuos3 6x8 cursor"
or
xinput --test 12

does not produce any output in konsole

Here is full output:
xinput --list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Macintosh mouse button emulation          id=7    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=8    [slave  pointer  (2)]
⎜   ↳ Genius Optical Mouse                      id=10   [slave  pointer  (2)]
⎜   ↳ Wacom Intuos3 6x8 eraser                  id=11   [slave  pointer  (2)]
⎜   ↳ Wacom Intuos3 6x8 cursor                  id=12   [slave  pointer  (2)]
⎜   ↳ Wacom Intuos3 6x8 pad                     id=13   [slave  pointer  (2)]
⎜   ↳ Wacom Intuos3 6x8                         id=14   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=6    [slave  keyboard (3)]
    ↳ HP Webcam                                 id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=15   [slave  keyboard (3)]
    ↳ Power Button                              id=16   [slave  keyboard (3)]
    ↳ Video Bus                                 id=17   [slave  keyboard (3)]
    ↳ Power Button                              id=18   [slave  keyboard (3)]

One observation about Qt and tablets:
People claim that Qt uses xlsatoms for detecting tablet.

see qt/src/gui/kernel/qapplication_x11.cpp line 318 in Qt4.6.x

Another user used to have older version of the driver xorg-x11-drv-wacom and the cmd "xlsatoms | grep Wacom" he used to have 3-4 entries in there, but after the update, similar list to my list. Longer list, not working tablet pressure in Qt apps. - on Arch linux though.

Is there any sense to try to compile linuxwacom project to update the kernel driver? I doubt but I'm trying to suggest something so that I can fix that.
I tried the linuxwacom 0.8.4-4 but probably due to X Server 1.7.5 in Fedora it failed as it suppose to work up to 1.6.x
Comment 3 Peter Hutterer 2010-03-01 17:49:11 EST
(In reply to comment #2)
> xinput --test "Wacom Intuos3 6x8 cursor"

the cursor device is the mouse device that wacom supplies as an extra to some tablets. the stylus is the "Wacom Intuos3 6x8" in your case (device 14). Please try that one too.
Comment 4 Peter Hutterer 2010-03-01 22:47:14 EST
reassigning to qt.

qt checks for hardcoded type names to see if a wacom device is present. these atom names are
      "Wacom Stylus\0"
      "Wacom Cursor\0"
      "Wacom Eraser\0"
see qt source, qapplication_x11.cpp:316

xorg-x11-drv-wacom fixed a bug in assigning these names where the device would overwrite itself and mess up the device names. The type names used now are "STYLUS", "CURSOR", "ERASER", "PAD" and "TOUCH" for each respective device. qt hence doesn't find the devices anymore and it appears that no device is available even though the device itself is working.

qt should check for these new type names instead of the ones above.
Comment 5 Kevin Kofler 2010-03-02 01:01:51 EST
I think openSUSE has been carrying a Qt patch for that or something similar for a while, we need to check it.
Comment 6 Lukas Tvrdy 2010-03-02 09:55:09 EST
@Kevin: I investigated this package http://download.opensuse.org/source/factory/repo/oss/suse/src/libqt4-4.6.2-1.3.src.rpm

I copied the patches from CONTENTS.cpio and I was greping for qapplication_x11
and tablet and stylus. But I did not find anything related. 

Btw OpenSUSE 11.2 uses still X server 1.6.x and linuxwacom driver.So probably they don't patch yet. Qt is 4.6 there.
Comment 7 Lukas Tvrdy 2010-03-02 10:15:43 EST
(In reply to comment #3)
> (In reply to comment #2)
> > xinput --test "Wacom Intuos3 6x8 cursor"
> 
> the cursor device is the mouse device that wacom supplies as an extra to some
> tablets. the stylus is the "Wacom Intuos3 6x8" in your case (device 14). Please
> try that one too.    

This worked, example output:
motion a[0]=21453 a[1]=19048 a[2]=0 a[3]=42 a[4]=-7 a[5]=0 
motion a[0]=21534 a[1]=19082 a[2]=0 a[3]=40 a[4]=-7 a[5]=0 
motion a[0]=21628 a[1]=19111 a[2]=0 a[3]=37 a[4]=-7 a[5]=0 
motion a[0]=21722 a[1]=19137 a[2]=0 a[3]=33 a[4]=-7 a[5]=0 
motion a[0]=21814 a[1]=19159 a[2]=0 a[3]=30 a[4]=-7 a[5]=0 
motion a[0]=21901 a[1]=19182 a[2]=0 a[3]=26 a[4]=-7 a[5]=0 
motion a[0]=21986 a[1]=19204 a[2]=0 a[3]=22 a[4]=-6 a[5]=0 
...

Seems like pressure and tilt work.
Comment 8 Dirk Mueller 2010-03-02 10:28:41 EST
(In reply to comment #5)
> I think openSUSE has been carrying a Qt patch for that or something similar for
> a while, we need to check it.    

No, not yet for Qt 4.x
Comment 9 Martin Klapetek 2010-03-03 17:42:06 EST
Confirming this on TabletPC hp tx2500z. Pen has no sensitivity in Qt applications. I'm on Fedora 12 - 2.6.32.8-58.fc12.x86_64, KDE 4.4.0, Qt 4.6.2, xorg-x11-drv-wacom-0.10.4-2, all 64bit.
Comment 10 Ngo Than 2010-03-05 09:13:58 EST
it should be fixed  in qt-4_6_2-5_fc12
Comment 11 Martin Klapetek 2010-03-05 12:41:16 EST
Confirming, pressure sensitivity works again in Krita, thanks :)
Comment 12 Fedora Update System 2010-03-14 16:22:33 EDT
qt-4.6.2-7.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/qt-4.6.2-7.fc13
Comment 13 Fedora Update System 2010-03-14 20:23:23 EDT
qt-4.6.2-7.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/qt-4.6.2-7.fc12
Comment 14 Fedora Update System 2010-03-15 20:39:40 EDT
qt-4.6.2-7.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/qt-4.6.2-7.fc12
Comment 15 Fedora Update System 2010-03-15 20:39:51 EDT
qt-4.6.2-7.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/qt-4.6.2-7.fc13
Comment 16 Fedora Update System 2010-03-18 11:45:19 EDT
qt-4.6.2-8.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qt-4.6.2-8.fc11
Comment 17 Fedora Update System 2010-03-22 22:09:41 EDT
qt-4.6.2-8.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2010-03-22 22:23:49 EDT
qt-4.6.2-8.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2010-03-22 22:24:03 EDT
qt-4.6.2-8.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.