Bug 569192 - Good IPv4 eth0 connection marked invalid even when it is only IPv6 DHCP that failed
Good IPv4 eth0 connection marked invalid even when it is only IPv6 DHCP that ...
Status: CLOSED DUPLICATE of bug 565926
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
12
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-28 11:48 EST by Al Thomas
Modified: 2010-03-01 21:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-01 21:52:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages - IP info obscured (4.67 KB, text/plain)
2010-02-28 11:48 EST, Al Thomas
no flags Details

  None (edit)
Description Al Thomas 2010-02-28 11:48:43 EST
Created attachment 396886 [details]
/var/log/messages - IP info obscured

Description of problem:
NetworkManager has default set up of configuring both IPv4 and IPv6 connections on eth0. This works well.

Today the DHCP for IPv6 is not working with my ISP. NetworkManager then disables the connection so no Internet connectivity at all. 

/var/log/messages (attached) shows it is just the IPv6 negotiation that fails and the IPv4 is fine. 

This can be worked around by going to NetworkManager Edit Connections and changing IPv6 Settings method to 'Ignore'. This then allows the connection to be established with the Internet as IPv4 only.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.998-2.git20100106.fc12.i686

How reproducible:
Every time

Steps to Reproduce:
1. Click on NetworkManager icon to connect
2. 
3.
  
Actual results:
NetworkManager icon changes to show it is trying to connect then cross appears to show connection failed.

Expected results:
Connection should be made, but only using IPv4

Additional info:
Comment 1 Dan Williams 2010-03-01 21:52:16 EST
I believe it's a bug that NM will try IPv6 by default; we should fix that.  For now it should only be on when you turn it on from the connection editor or your system configuration files (/etc/sysconfig/network-scripts/ifcfg-*) set it on.

With that in mind, duping to bug 565926.

*** This bug has been marked as a duplicate of bug 565926 ***

Note You need to log in before you can comment on or make changes to this bug.