Bug 56930 - 2.2.2 kde rpm's mispackaged
2.2.2 kde rpm's mispackaged
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kdelibs (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-30 11:21 EST by Bryce Nesbitt
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-30 11:22:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryce Nesbitt 2001-11-30 11:21:39 EST
The kde 2.2.2 rpm's have been mispackaged.  Starting with a base of RedHat
7.2 fully "up2date", and using the entire contents of the kde 2.2.2
distribution directory with "rpm -Uvh *.rpm" should work.

It does not.  There are dozens of failed dependencies.  Even this fails:

[root@HardHat i386]# rpm -Uvh kdelibs-2.2.2-1.i386.rpm
kdebase-2.2.2-1.i386.rpm
error: failed dependencies:
	libfam.so.0   is needed by kdelibs-2.2.2-1
	libpcreposix.so.0   is needed by kdelibs-2.2.2-1
	libpcre.so.0   is needed by kdelibs-2.2.2-1
	kdelibs-sound >= 2.2.2 is needed by kdebase-2.2.2-1
	libvorbis is needed by kdebase-2.2.2-1
	libfam.so.0   is needed by kdebase-2.2.2-1
	libartskde.so   is needed by kdebase-2.2.2-1
	libcrypto.so.2   is needed by kdebase-2.2.2-1
	libssl.so.2   is needed by kdebase-2.2.2-1
	kdesupport is needed by kdeadmin-2.1.1-3
	kdesupport is needed by kdemultimedia-2.1.1-1
	kdesupport is needed by kdenetwork-2.1.1-1
	kdesupport is needed by koffice-2.0.1-2
	kdesupport is needed by kpppload-1.04-23
	kdesupport is needed by kdeutils-2.1.1-1
	kdesupport is needed by kdbg-1.2.0-3
	kdesupport is needed by kdegames-2.1.1-1
	kdesupport is needed by kdegraphics-2.1.1-1
	kdesupport is needed by kdetoys-2.1.1-2
	kdesupport = 2.1 is needed by kdesupport-devel-2.1-3
	kdelibs = 2.1.2 is needed by kdelibs-devel-2.1.2-1
	kdelibs = 2.1.2 is needed by kdelibs-sound-2.1.2-1
	kdelibs = 2.1.2 is needed by kdelibs-sound-devel-2.1.2-1

Given this state, only an expert could unwind this mess.

(I run KDE in my home directory, compiled from source, but I wanted to
upgrade
my stock 7.2 system).
Comment 1 Bryce Nesbitt 2001-11-30 11:22:20 EST
[root@HardHat i386]# rpm -q -i -p kdelibs-2.2.2-1.i386.rpm 
Name        : kdelibs                      Relocations: /usr 
Version     : 2.2.2                             Vendor: Red Hat, Inc.
Release     : 1                             Build Date: Tue 20 Nov 2001 07:45:05
EST
Install date: (not installed)               Build Host:
stripples.devel.redhat.com
Group       : System Environment/Libraries   Source RPM:
kdelibs-2.2.2-1.src.rpmSize        : 21928167                         License:
LGPL
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : Various libraries for KDE.
Comment 2 Bernhard Rosenkraenzer 2001-11-30 11:36:12 EST
Whatever you were starting from is most definitely not a 7.2 system:
1) We didn't ship KDE 2.1.1, 7.2 came with KDE 2.2.
2) pcre, fam and OpenSSL 0.9.6b were in 7.2 all the time, and the stock
KDE packages on 7.2 were linked against them, so if KDE ever worked on your
system and it was indeed 7.2, you'd have them installed.
3) kdesupport wasn't around in 7.2, and never required by any 7.2 packages.

This looks like you're trying to update a 7.0 or 7.1 system without installing
the required packages from 7.2 (namely, pcre, fam, current OpenSSL, current
KOffice). Also, you appear to be missing the kdelibs-sound 2.2.2 packages.
Comment 3 Bryce Nesbitt 2001-11-30 12:36:34 EST
Hmmm... you're right.  It was a 7.1 system.  Nothing obvious tells
you the RedHat release number, and I assumed wrong.  Sorry.

Note You need to log in before you can comment on or make changes to this bug.