Bug 569302 - Please upgrade to tracker 0.7 release
Please upgrade to tracker 0.7 release
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tracker (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
: Reopened
Depends On: 572233
Blocks: MeeGo1
  Show dependency treegraph
 
Reported: 2010-03-01 03:19 EST by Peter Robinson
Modified: 2010-05-04 02:19 EDT (History)
3 users (show)

See Also:
Fixed In Version: tracker-0.8.4-1.fc13.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-04 02:19:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2010-03-01 03:19:53 EST
The current tracker release is 0.7.23 and is available

http://ftp.gnome.org/pub/GNOME/sources/tracker/0.7/tracker-0.7.23.tar.bz2

It would be great to upgrade to 0.7. A number of features in Moblin currently want the features in the 0.7 release.
Comment 1 Deji Akingunola 2010-03-01 08:57:44 EST
The 0.7 series of tracker is (as advertised by the upstream) an unstable one, where new stuff are being aggressively worked one, and api/tracker db can change.
I believe the more stable tracker-0.8 is due to be released soon; that will be in rawhide as soon as it happens.
Comment 2 Peter Robinson 2010-03-01 12:28:32 EST
And the 0.6.9x release was pre release version for 0.7 as well so it is of no difference in that regard.
Comment 3 Deji Akingunola 2010-03-01 12:39:21 EST
(In reply to comment #2)
> And the 0.6.9x release was pre release version for 0.7 as well so it is of no
> difference in that regard.    

No it's not, 0.6.9x is a continuation of the 0.6.x series; the 0.7 series is a sort of tracker re-write.
Comment 4 Bastien Nocera 2010-03-02 11:20:57 EST
Reopening, as this should be done in F14 ASAP, so we can fix the fallouts from the upgrade.

Given how bad the old Tracker was (more specifically the indexer part), I don't think anyone will mind seeing the back of it...
Comment 5 Deji Akingunola 2010-03-02 12:20:41 EST
(In reply to comment #4)
> Reopening, as this should be done in F14 ASAP, so we can fix the fallouts from
> the upgrade.
> 
I'm just trying to be careful here not putting an unstable package in a stable Fedora release as I have no indication of the particular release date for tracker-0.8. For instance, if I had put the 0.7.x in rawhide 2 months ago when people started asking for it, then F-13 would have ship with it. Meawhile the upstream developers have continually maintained the APIs/ontologies are still subject to changes in the 0.7.x until 0.8 is released.
Besides some of the user-visible features of tracker (such as deskbar-applet support) are not yet ported to the 0.7.x series.
  
> Given how bad the old Tracker was (more specifically the indexer part), I don't
> think anyone will mind seeing the back of it...
Comment 6 Peter Robinson 2010-03-02 12:36:48 EST
F-14 isn't due until end of October
Comment 7 Deji Akingunola 2010-03-02 13:01:34 EST
(In reply to comment #6)
> F-14 isn't due until end of October    

Do you know when tracker-0.8 is due? As I stated before, I'm not trying to be difficult but just want to play it safe, tracker-0.6.x is already 'bad' enough.
I'll go ahead and put tracker-0.7.23 in rawhide.
Comment 8 Deji Akingunola 2010-03-10 13:24:58 EST
I've learnt that tracker-0.8 will likely be released by the end of this month (03/2010). So I will try and get the latest 0.7 release into F13 asap (it's already in rawhide). However as there is(are?) a package which depends on the old tracker-0.6 api, I've submitted a new package bug for a compat-tracker at https://bugzilla.redhat.com/show_bug.cgi?id=572233.
Please help review the new package if you have the time/inclination, so I can introduce tracker-0.7/0.8 into F13. Thanks.
Comment 9 Peter Robinson 2010-03-10 16:45:51 EST
Great! I suspected it might have been released to coincide with gnome 2.30 :-)
Comment 10 Peter Robinson 2010-03-13 03:52:08 EST
Thanks for getting it into F-14/rawhide. Can we get it into F-13 as well before long? Heads up to fedora-devel might be good.
Comment 11 Deji Akingunola 2010-03-13 13:40:57 EST
(In reply to comment #10)
> Thanks for getting it into F-14/rawhide. Can we get it into F-13 as well before
> long? Heads up to fedora-devel might be good.    

Please see comment #8.
Comment 12 Peter Robinson 2010-04-02 10:37:40 EDT
(In reply to comment #8)
> I've learnt that tracker-0.8 will likely be released by the end of this month
> (03/2010). So I will try and get the latest 0.7 release into F13 asap (it's
> already in rawhide). However as there is(are?) a package which depends on the
> old tracker-0.6 api, I've submitted a new package bug for a compat-tracker at
> https://bugzilla.redhat.com/show_bug.cgi?id=572233.
> Please help review the new package if you have the time/inclination, so I can
> introduce tracker-0.7/0.8 into F13. Thanks.    

Doing a repoquery against tracker and its libs it looks like other than tracker subpackages themselves there are two other packages that depend on tracker. One is catfish-engines and the other is rygel of which I'm the maintainer and can deal with the upstream if necessary for 0.8 support now that its out. I'm not sure I see the point of a compat package as a result. 

# repoquery --whatrequires tracker
tracker-devel-0:0.6.96-3.fc12.i686
rygel-tracker-0:0.4.12-1.fc12.x86_64
catfish-engines-0:0.3.2-3.fc12.noarch
tracker-devel-0:0.6.95-3.fc12.x86_64
tracker-devel-0:0.6.96-3.fc12.x86_64
tracker-search-tool-0:0.6.96-3.fc12.x86_64
tracker-devel-0:0.6.95-3.fc12.i686
tracker-search-tool-0:0.6.95-3.fc12.x86_64
rygel-tracker-0:0.4.2-1.fc12.x86_64
Comment 13 Peter Robinson 2010-04-02 10:55:04 EDT
Rygel builds fine in F-14 against tracker 0.8
http://koji.fedoraproject.org/koji/taskinfo?taskID=2091364
Comment 14 Deji Akingunola 2010-04-02 20:35:24 EDT
(In reply to comment #12)
> (In reply to comment #8)
> > I've learnt that tracker-0.8 will likely be released by the end of this month
> > (03/2010). So I will try and get the latest 0.7 release into F13 asap (it's
> > already in rawhide). However as there is(are?) a package which depends on the
> > old tracker-0.6 api, I've submitted a new package bug for a compat-tracker at
> > https://bugzilla.redhat.com/show_bug.cgi?id=572233.
> > Please help review the new package if you have the time/inclination, so I can
> > introduce tracker-0.7/0.8 into F13. Thanks.    
> 
> Doing a repoquery against tracker and its libs it looks like other than tracker
> subpackages themselves there are two other packages that depend on tracker. 

You missed the one dependent package that really needs the compat-tracker package, 'paperbox'.
It is not trivial (at least for me and the Fedora maintainer) to update paperbox to tracker-0.8 api, and the upstream developer has stated he has no intention of doing that any time soon.
Comment 15 Peter Robinson 2010-04-04 09:43:26 EDT
> You missed the one dependent package that really needs the compat-tracker
> package, 'paperbox'.
> It is not trivial (at least for me and the Fedora maintainer) to update
> paperbox to tracker-0.8 api, and the upstream developer has stated he has no
> intention of doing that any time soon.    

True, I did miss that but paperbox doesn't build on F-13 anyway due to breakage in gtkmm

https://bugzilla.gnome.org/show_bug.cgi?id=610804

As can been seen in koji

http://koji.fedoraproject.org/koji/packageinfo?packageID=9099

And what's more there's not been a single code based commit to upstream in 6+ months
Comment 16 Hicham HAOUARI 2010-04-23 11:48:20 EDT
catfish development has stalled since 2008-10-24 ( edit date of this page : http://software.twotoasts.de/index.php?/pages/catfish_summary.html ).

maybe we should cc mtasaka
Comment 17 Fedora Update System 2010-04-26 01:04:09 EDT
tracker-0.8.3-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/tracker-0.8.3-1.fc13
Comment 18 Fedora Update System 2010-04-26 22:14:23 EDT
tracker-0.8.3-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tracker'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/tracker-0.8.3-1.fc13
Comment 19 Fedora Update System 2010-04-30 19:37:19 EDT
tracker-0.8.4-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tracker'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/tracker-0.8.4-1.fc13
Comment 20 Fedora Update System 2010-05-04 02:19:43 EDT
tracker-0.8.4-1.fc13.1, tracker-0.8.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.