Bug 569427 - Wrong directory ownership
Wrong directory ownership
Status: CLOSED DUPLICATE of bug 477486
Product: Fedora
Classification: Fedora
Component: xorg-x11-fonts (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 559592
  Show dependency treegraph
 
Reported: 2010-03-01 09:18 EST by Ondrej Vasik
Modified: 2010-05-29 02:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-29 02:51:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ondrej Vasik 2010-03-01 09:18:38 EST
Based on the check done on F-12 system, your package owns directories owned by filesystem. 
This is not allowed by Fedora policies. 

See http://fedoraproject.org/wiki/Packaging/Guidelines#File_and_Directory_Ownership 
for details.

(Sub)package xorg-x11-fonts-misc:
/etc/X11/fontpath.d
(Sub)package xorg-x11-fonts-ISO8859-14-100dpi:
/etc/X11/fontpath.d
(Sub)package xorg-x11-fonts-ISO8859-1-75dpi:
/etc/X11/fontpath.d
(Sub)package xorg-x11-fonts-100dpi:
/etc/X11/fontpath.d
(Sub)package xorg-x11-fonts-ISO8859-9-100dpi:
/etc/X11/fontpath.d
(Sub)package xorg-x11-fonts-cyrillic:
/etc/X11/fontpath.d
(Sub)package xorg-x11-fonts-75dpi:
/etc/X11/fontpath.d
(Sub)package xorg-x11-fonts-ISO8859-9-75dpi:
/etc/X11/fontpath.d
(Sub)package xorg-x11-fonts-ISO8859-15-75dpi:
/etc/X11/fontpath.d
(Sub)package xorg-x11-fonts-ISO8859-1-100dpi:
/etc/X11/fontpath.d
(Sub)package xorg-x11-fonts-ISO8859-14-75dpi:
/etc/X11/fontpath.d
(Sub)package xorg-x11-fonts-ISO8859-15-100dpi:
/etc/X11/fontpath.d
(Sub)package xorg-x11-fonts-Type1:
/etc/X11/fontpath.d
(Sub)package xorg-x11-fonts-ISO8859-2-75dpi:
/etc/X11/fontpath.d
(Sub)package xorg-x11-fonts-ethiopic:
/etc/X11/fontpath.d
(Sub)package xorg-x11-fonts-ISO8859-2-100dpi:
/etc/X11/fontpath.d

This is autogenerated bugzilla, I'm sorry if the problem is already fixed or reported. Additionally I apologize if that directory ownership was requested earlier by some bugzilla (some directories were probably added into filesystem package later, so your package should no longer own that directory).
Comment 1 Ondrej Vasik 2010-03-01 15:41:13 EST
Still exists with xorg-x11-fonts-<subpackage>-0:7.2-9.fc12.noarch .
Comment 2 Matěj Cepl 2010-05-29 02:51:02 EDT
Should be dealt with during the whole redoing of all the packaging work.

*** This bug has been marked as a duplicate of bug 477486 ***

Note You need to log in before you can comment on or make changes to this bug.