Bug 56943 - rpm 4.0.2 ignores buildrequires in noarch rpms
rpm 4.0.2 ignores buildrequires in noarch rpms
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-30 15:24 EST by Gregory Leblanc
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-30 15:24:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregory Leblanc 2001-11-30 15:24:47 EST
Description of Problem:
rpmbuild appears to ignore BuildRequires lines when the spec file contains
BuildArch: noarch.

Version-Release number of selected component (if applicable):
4.0.2

How Reproducible:
every time

Steps to Reproduce:
1. download sgml-common from rawhide
2. remove libxml2
3. rebuild sgml-common srpm

Actual Results:
rpm attempts to compile sgml-common

Expected Results:
rpm display error stating that build dependancies aren't met.

Additional Information:
This happens on both the rpm shipped with Red Hat Linux 6.2 and 7.0 as
errata (rpm 4.0.2).  It doesn't show up on the RPM shipped with Red Hat
Linux 7.2, which is rpm 4.0.3
Comment 1 Jeff Johnson 2001-12-02 13:38:11 EST
The fix for this is gonna be rpm-4.0.3, in the pipes now.
The release to ftp.rpm.org is in the pipes now, the errata is
gonna take a bit longer. Meanwhile, penultimate bits
are at ftp://ftp.rpm.org/pub/rpm/test-4.0.3, been there for months,
6x as well.
Comment 2 Gregory Leblanc 2001-12-02 17:56:26 EST
I can't find any proposed errata for rpm 4.0.3 on any platform.
Comment 3 Jeff Johnson 2001-12-02 18:23:38 EST
Huh? The "official" rpm-4.0.3 release has been promised for months.
The errata release will happen afterwards, and will be rate limited by
whatever QA chooses to do. No, it's not out yet, the "official" rlease
will probebaly be there tomorrow.
Meanwhile, did you look at  the URL? Those bits are identical to
what was released in Red Hat 7.2, but not yet "officially" released.
Comment 4 Gregory Leblanc 2001-12-02 18:36:52 EST
Ah, oops.  I thought that since Red Hat Linux 7.2 shipped with RPM 4.0.3, that
it had been "officially" released.  I was browsing the beta site errata list
looking for it, but didn't see anything.  Sorry about the confusion.
Comment 5 Jeff Johnson 2001-12-02 18:49:05 EST
<grin> 
No problem, rpm has a very confusing release cycle.

Note You need to log in before you can comment on or make changes to this bug.