Bug 56948 - repeated anaconda crashes during package install
repeated anaconda crashes during package install
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-30 17:31 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-15 16:40:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Comment (68.03 KB, text/plain)
2001-12-01 15:39 EST, Olaf Scheunemann
no flags Details

  None (edit)
Description Need Real Name 2001-11-30 17:31:11 EST
Description of Problem:

Anaconda keeps crashing during the copy-and-install-packages portion of
the install. It has crashed anywhere from 1/5th of the way done to 3/4
of the way done and seems unaffected by which packages I choose to
install. This is with the "custom" install option.

Version-Release number of selected component (if applicable):
n/a

How Reproducible:
always

Steps to Reproduce:

1. boot computer from bootnet.img
2. begin install from nfs share as usual. select custom (haven't tried
other install options), autopartition, yada yada
3. sometime during the package install progress, anaconda crashes. I can
still switch vts, use the shell etc.


Actual Results:

el crasho (see above). I am using slightly non-standard HW (a pc104
stack) but it's got a vanilla pentium 166 processor, normal-ish (128MB
SODIMM) RAM, etc.

Expected Results:
A proper install would be the expected result.

Additional Information:

Here's a dump of what anaconda spews on crash. It's mostly the same each
time (tried 4 times now) and I have noted in parentheses where the
dumped data varies.


unable to handle kernel paging request at virtual address edb794ad
(the virtual address varies)

printing eip:
c01408e9
*pde = 00000000
Oops: 0002
CPU: 0
EIP: 0010:[<c01408e9>]

(all that is always the same).


EFLAGS: 00010a83
(sometimes 00010287)

eax: edb794a9 ebx: c3fbd0b0 ecx: ddaf05c7 edx: c3fbd0b8
esi: c7cce800 edi: 00000007 ebp: c7cce800 esp: c7da5e70
(these vary)

ds: 0018 es: 0018 ss: 0018
Process anaconda (pid: 11, stackpage=c7da5000)

(always the same)

Stack:
0000003f 000fba8b 00000260 c014c42b c3fbd0b0 00000007 c4e27a80 00003fe0
c36dac30 c3fbd0b0 c2032400 c765d7e0 0000003f c4e27a80 c72f7900 c7da5f08
5b513da2 c7da5f84 c611c020 c36dac30 fffffff3 c454d740 c454d740 c014dfe3

(stack contents vary as you might expect)

Call Trace: [<co14c42b>] [<c014dfe3>] [c013901d>] [c0138eaa>]
[<c01391aa>]
[<c012e7f6>] [<c012eab9>] [<c0106dbf>]

Code: 89 48 04 89 01 8b 46 58 8d 4e 58 89 50 04 89 43 08 89 4a 04

(both of those always the same)
Comment 1 Olaf Scheunemann 2001-12-01 15:39:54 EST
Created attachment 914992 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 2 Need Real Name 2001-12-03 11:28:41 EST
Whoever os@gcx,de is, I'd appreciate it if next time, you avoided posting
massive dumps of unrelated data to someone else's bug report... it looks to me
like you have a different problem (yes it's a problem with anaconda but likely
not the same one!). For example, I'm doing a network install, not a CD install,
and from your logs there's clearly a problem with reading from your CD-ROM.

Is there any way to split this into two bugs?
thanks
--Jim Morash
Comment 3 Michael Fulbright 2001-12-03 15:35:48 EST
No unfortunately we can't remove the extra message. If you want to refile the
bug we could do that, and close this one.

BTW, have you tried a minimum install?  The oops you are seeing looks like it
may be running out of RAM, but with 128M that shouldn't be happening.
Comment 4 Need Real Name 2001-12-11 13:32:34 EST
I agree that it seems unlikely that it's a RAM problem. I'm unable to experiment
with the computer at the moment as it's in a robot that's in use (it boots fine
with a pre-installed HD, but being able to install is an important capability).
Should I just reopen this bug when I can do more testing?
Comment 5 Jeremy Katz 2001-12-12 15:33:57 EST
Do you know if this machine's memory is fine?  (You can test with something like
memtest86)
Comment 6 Need Real Name 2001-12-12 17:17:32 EST
I don't know. I may be able to test it sometime tomorrow. However, we've been
running it on our robot for about eight hours a day for the last week and have
had no crashes.
Comment 7 Need Real Name 2002-01-02 01:07:41 EST
A quick comment on osa@cgx.de's bug, it is a failure of anaconda to ask for 
disk two, so anaconda crashes. It is bug #57842
Comment 8 Mike Bowler 2002-01-04 02:49:56 EST
Anaconda crashed on me (ouch, painful) during a similar situation.  The
differences are:

1 - I used the "Laptop" install selection
2 - I was installing over FTP

I saved the crash data if that would be helpful.
Comment 9 Michael Fulbright 2002-01-15 16:40:52 EST
If you are not the original bug poster please open a new bug with your issues.

Putting back into NEEDINFO state because we are waiting on a response from the
original bug poster.
Comment 10 Brent Fox 2002-01-26 22:38:48 EST
Closing due to inactivity.  Please reopen if you have more information.

Note You need to log in before you can comment on or make changes to this bug.