Bug 569496 - Installer hangs after adding many RAID members
Installer hangs after adding many RAID members
Status: CLOSED DUPLICATE of bug 567576
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-03-01 10:52 EST by James Laska
Modified: 2013-09-02 02:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-01 16:52:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/tmp/log*.tgz (34.23 KB, application/x-gzip)
2010-03-01 10:52 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2010-03-01 10:52:15 EST
Created attachment 397096 [details]
/tmp/log*.tgz

Description of problem:

Installer hangs after adding a certain number of partitions

Version-Release number of selected component (if applicable):
 * anaconda-13.32

How reproducible:
 * 4 out of 4 attempts in virt

Steps to Reproduce:

    Disk layout:
     * vda - 10G
     * vdb - 2G
     * vdc - 512M
     * vdd - 512M

    1. Create /boot on vda (size: default)
    2. Create LVM PV on vdc (size: fill disk)
    3. Create LVM PV on vdd (size: fill disk)
    4. Create LVM PV on vdb (size: fill disk)
    5. Create Logical volume group
     * swap - 512M
     * / - remaining space in vg
    6. Create a RAID device on vda (size: 2048)
    7. Create a RAID device on vda (size: 2048)
    8. Create a RAID device on vda (size: 2048)

Actual results:

The UI hangs and it seems after selecting 'OK' in last step above.

Expected results:

I should be able to add the device

Additional info:

 * I've seen this before while adding lots of LVM PV's.  Perhaps an implicit maximum # of partitions somewhere?
Comment 1 Hans de Goede 2010-03-01 16:52:42 EST
We've an issue in pyparted which gets triggered by creating a lot, with a lot varying between 3-5 partitions.

This issue has been pinpointed and a fix is on its way, marking this as a duplicate of the bug tracking the pyparted feature in Fedora.

*** This bug has been marked as a duplicate of bug 567576 ***

Note You need to log in before you can comment on or make changes to this bug.