Bug 56957 - Bad Config.in in kernel-source-2.4.9-13
Bad Config.in in kernel-source-2.4.9-13
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-30 21:17 EST by Philippe Rigault
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 19:04:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Rigault 2001-11-30 21:17:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120

Description of problem:
I installed kernel-source-2.4.9-13 and opened the 'Linux Kernel
Configurator' from the KDE (I am using the latest version: 2.2.2) control
center (after having made a symbolic link from /usr/src/linux to
/usr/src/linux-2.4.9-13 since this is where the kernel configurator looks).
Immediately, the kernel configuration tool came up with this message:
  The kernel configuration could not be read due to the following error
  /usr/src/linux/drivers/hotplug/Config.in, line 4
  mainmenu_option next_commnet # THE WORD next_commnet WAS IN RED
  ...

So I went ahead and replaced that line with 'next_comment' instead of
'next_commnet', and the kernel configurator was happy.

Bottomline is:
  - there is a bug in line 4 of this Config.in that needs to be fixed
  - KDE kernel configurator is good for you since it ACTUALLY CHECKS the
validity of kernel config parameters before you actually compile them
(thank you KDE, this thing rocks). I have no idea how it actually checks
the parameters in config.in files, and would be interested to find out. 
  - 'make xconfig' does not check this, it would be a good thing that it does. 




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install kernel-source-2.4.9-13
2.start KDE control center (I am using the 2.2.2, but the default RedHat
7.2 should giv the same behaviour)
3.click on Linux Kernel Configurator (under System)
	

Actual Results:  Error message

Expected Results:  It should work

Additional info:

Note You need to log in before you can comment on or make changes to this bug.