Bug 569579 - No sound in virtual machine
No sound in virtual machine
Status: CLOSED DUPLICATE of bug 508317
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-01 14:03 EST by Stephen Haffly
Modified: 2010-06-17 13:15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-27 17:58:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Haffly 2010-03-01 14:03:10 EST
Description of problem:
I have made a virtual machine using virt-manager 0.8.2 in Fedora 12, 64 bit, which reports that it is using qemu as the hypervisor when I view the host details and kvm as the hypervisor and /usr/bin/qemu-kvm as the emulator with i686 as the emulated platform.  I installed Vista Home Premium into this virtual machine.  Although it reports that it sees the audio setup and reports that it is working correctly, I have no sound output from Vista.  Sound is working fine for Fedora 12.


Version-Release number of selected component (if applicable):
virt-manager-0.8.2-1.fc12.noarch
libvirt-0.7.1-15.fc12.x86_64



How reproducible:
Seems to be very consistent.  I have read on Fedora Forum that others have been experiencing this same problem

Steps to Reproduce:
1. create virtual machine
2. install Vista

  
Actual results:
no sound output

Expected results:
should have sound output

Additional info:
uname -a
Linux emerald.hhome 2.6.31.12-174.2.22.fc12.x86_64 #1 SMP Fri Feb 19 18:55:03 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux
Hardware is HP Pavilion a1610n with 4 Gb RAM (dual-core AMD 64 Live processor)
Comment 1 Cole Robinson 2010-05-27 17:58:50 EDT
Known issue, there are several bugs about this filed against libvirt. Pretty soon I'll be writing up instructions how to work around this. Duping to a libvirt bug for now.

*** This bug has been marked as a duplicate of bug 508317 ***
Comment 2 Jonathan Underwood 2010-06-16 16:58:43 EDT
Cole - any pointer to your notes on how to work around this?
Comment 3 Cole Robinson 2010-06-17 10:03:00 EDT
Making it work depends on some backport patches that aren't built yet (but I'll do it today, I swear :) Once that build is available, I'll write up notes in the duped bug.
Comment 4 Jonathan Underwood 2010-06-17 13:15:48 EDT
Excellent, thanks Cole.

Note You need to log in before you can comment on or make changes to this bug.