Bug 56961 - tmpwatch can't handle large files
Summary: tmpwatch can't handle large files
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tmpwatch   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-01 14:04 UTC by Mike A. Harris
Modified: 2007-04-18 16:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 23:36:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike A. Harris 2001-12-01 14:04:36 UTC
Description of Problem:
tmpwatch blows up on 18Gb files

error: failed to lstat /tmp/plugtmp/terahertz4.tif: Value too large for
defined data type

Version-Release number of selected component (if applicable):
tmpwatch-2.7.1-1

How Reproducible:
100%

Steps to Reproduce:
1. put an 18 gigabyte file in /tmp
2. run tmpwatch via cron
3. read root's email

Actual Results:
Date: Tue, 27 Nov 2001 04:02:42 -0500
From: Cron Daemon <root@zod.capslock.lan>
To: root@zod.capslock.lan
Subject: Cron <root@zod> run-parts /etc/cron.daily
 
/etc/cron.daily/tmpwatch:
 
error: failed to lstat /tmp/plugtmp/terahertz4.tif: Value too large for
defined data type


Expected Results:
tmpwatch treating the file like any other file, and hopefully
removing that huge beast.

Additional Information:
No, I am not insane.  I do not usually have 18Gb files laying
around.  ;o)  Mozilla created this beast when trying to display
an 8Mb TIFF image.  It somehow went berzerk and my machine almost
had a kernel panic due to a shortage of DMA buffers for SCSI.
18Gb files are bad bad bad.  tmpwatch should delete them.  ;o)

Comment 1 Mike A. Harris 2002-01-24 23:36:42 UTC
Wow, I've been reassigned my own bug report.  Fun.  ;o)

Comment 2 Mike A. Harris 2002-04-13 10:19:43 UTC
And finally I've gotten around to fixing it too.  ;o)

Added the following to CFLAGS

-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64

Will appear in rawhide tmpwatch 2.8.3


Note You need to log in before you can comment on or make changes to this bug.