Bug 56966 - cron seems to ignore NIS users
cron seems to ignore NIS users
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: vixie-cron (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-01 11:46 EST by Richard Allen
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 19:02:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Allen 2001-12-01 11:46:46 EST
Description of Problem:
I have a bunch of machines where one of them is a master NIS server and 
the rest are NIS clients.  Users that are not in /etc/passwd, but in NIS 
maps dont get their crontabs run.

Version-Release number of selected component (if applicable):
vixie-cron-3.0.1-63

How Reproducible:
[quake@skjalfti4 quake]$ id
uid=500(quake) gid=500(quake) groups=500(quake)
[quake@skjalfti4 quake]$ grep quake /etc/passwd /etc/group
[quake@skjalfti4 quake]$ ypmatch quake passwd
quake:$1$QJKeF3qF$6.4j/gL2u73.p8FR59osv1:500:500:Quake Admin 
User:/home/quake:/bin/bash

[quake@skjalfti4 quake]$ crontab -l
# DO NOT EDIT THIS FILE - edit the master and reinstall.
# (/tmp/crontab.4421 installed on Sat Dec  1 16:38:11 2001)
# (Cron version -- $Id: crontab.c,v 2.13 1994/01/17 03:20:37 vixie Exp $)
# Athuga hvort AQ servernir siu ekki m gangi
*/5 * * * * /usr/local/games/tjekkaaq
# Roteita loggum f. statmstmk. Gera ~ap kl. 08:01.
01 08 * * * /usr/local/games/rotatelogs
[quake@skjalfti4 quake]$ ll /usr/local/games/tjekkaaq 
/usr/local/games/rotatelogs
-rwxr-xr-x    1 quake    quake         872 Sep 29 15:19 
/usr/local/games/rotatelogs
-rwxr-xr-x    1 quake    quake         668 Sep 29 15:19 
/usr/local/games/tjekkaaq

from /var/log/cron:
Dec  1 07:40:00 skjalfti4 CROND[3577]: (root) CMD (/usr/lib/sa/sa1 1 1)
Dec  1 07:50:00 skjalfti4 CROND[3580]: (root) CMD (/usr/lib/sa/sa1 1 1)
Dec  1 08:00:00 skjalfti4 CROND[3583]: (root) CMD (/usr/lib/sa/sa1 1 1)
Dec  1 08:01:00 skjalfti4 CROND[3586]: (root) CMD (run-parts 
/etc/cron.hourly)
Dec  1 08:10:00 skjalfti4 CROND[3591]: (root) CMD (/usr/lib/sa/sa1 1 1)
Dec  1 08:20:00 skjalfti4 CROND[3646]: (root) CMD (/usr/lib/sa/sa1 1 1)
Dec  1 08:30:00 skjalfti4 CROND[3649]: (root) CMD (/usr/lib/sa/sa1 1 1)
[root@skjalfti4 root]# ll /var/spool/cron/quake 
-rw-------    1 root     quake         365 Des  1 16:38 
/var/spool/cron/quake



Steps to Reproduce:
See above.

Actual Results:
Nothing seems to happen

Expected Results:
crontab should be run.

Additional Information:
Something strange is going on.
[quake@skjalfti4 games]$ date
Lau Des  1 16:45:39 GMT 2001
[quake@skjalfti4 games]$ ls -lu tjekkaaq 
-rwxr-xr-x    1 quake    quake         668 Des  1 16:45 tjekkaaq

Looks like somebody read the script at the same time cron was supposed to 
run it, but it didnt get run.
Comment 1 Eido Inoue 2002-02-13 15:58:35 EST
I can't reproduce the bug with the steps you've given. Simple tests over NFS/NIS
networks here (what we use internally here at Red Hat) seem to work. Can you
give an example that uses only the OS and not quake?
Comment 2 Jason Vas Dias 2004-08-30 19:02:11 EDT
Just clearing out old bugs here.
This definitely works OK in latest version : vixie-cron-4.1-10

Note You need to log in before you can comment on or make changes to this bug.