Bug 56971 - e2fsck in repair mode does not understand LABEL=
e2fsck in repair mode does not understand LABEL=
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: e2fsprogs (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-01 12:06 EST by Kjetil T. Homme
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-07 15:03:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjetil T. Homme 2001-12-01 12:06:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-13smp i686)

Description of problem:
If e2fsck needs to be run manually in rc.sysinit, you have to remember
where your filesystems are :-)  It does not understand the LABEL=foo
syntax.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
0. Use labels for your ext2 filesystems in /etc/fstab
1. crash your system horribly
2. reboot, wait for e2fsck to fail automatic recovery
3. try typing e2fsck LABEL=mm
4. look futilely in /etc/fstab
5. tear out your hair trying to remember on which disk and slice
   the filesystem is. :-)


Actual Results:  Since it is in repair mode, I didn't write down the actual
error
message, sorry.  It has happened to me in both RH 7.1 and 7.2.

Expected Results:  It should've done an fsck on /dev/hdg5 (see?  now I
know! :)


Additional info:

This is not a duplicate of 35980.
$ rpm -q e2fsprogs
e2fsprogs-1.23-2
$ rpm -q initscripts
initscripts-6.40-1
Comment 1 Kjetil T. Homme 2002-04-03 19:34:35 EST
In Skipjack, the problem in repair mode seems to be fixed, but now it doesn't
work in multiuser mode:

# grep mm /proc/mounts
/dev/hdg5 /mm ext3 rw 0 0
# grep mm /etc/fstab
LABEL=mm                /mm                     ext3    defaults        1 2
# umount /mm
# e2fsck LABEL=mm
e2fsck 1.27 (8-Mar-2002)
e2fsck: No such file or directory while trying to open LABEL=mm
# rpm -q e2fsprogs
e2fsprogs-1.27-1
Comment 2 Kjetil T. Homme 2002-04-07 15:03:13 EDT
Doh!  e2fsck doesn't understand LABEL=foo, but the fsck wrapper does.  My apologies.
Comment 3 Florian La Roche 2002-04-08 08:35:02 EDT
The wrapper should be ok.

Thanks,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.