Bug 56976 - [qlogic] Qlogic lun is "not a valid block device" after reboot
[qlogic] Qlogic lun is "not a valid block device" after reboot
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-12-01 16:39 EST by Clay Cooper
Modified: 2007-04-18 12:38 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-12-06 11:35:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Clay Cooper 2001-12-01 16:39:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4)
Gecko/20011019 Netscape6/6.2

Description of problem:
Bordeaux with qa1129 (2.4.9-17.3smp) installed, direct-attached qlogic2200
storage, and using new qla2200 driver.

After rebooting, attached storage partition and filesystem cannot be
mounted --  "mount: /dev/sde1 is not a valid block device"

I tried unloading and reloading the driver manually, still didn't work.

If you remake the partition table in parted (mklabel) and recreate the
partition, then you can mount it.

Reboot again, and it's not a valid block device.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Install qa1129 on a bordeaux w/ direct attached qlogic2200 storage.
2.  Create a partition and filesystem on a lun.  Mount it successfully.
3.  Reboot and note inability to mount.  Remake partition table and
partition to be able to mount again.

Actual Results:  Lun partition is not a valid block device after reboot.

Expected Results:  Should mount.

Additional info:
Comment 1 Arjan van de Ven 2001-12-05 06:28:37 EST
I've seen this before but cannot reproduce it with the current driver (2.4.9-17.4)
Comment 2 Clay Cooper 2001-12-05 15:45:44 EST
Reproduced w/ 2.4.9-17.4smp
Comment 3 Michael K. Johnson 2001-12-05 15:50:19 EST
>How reproducible:
>Additional comment by arjanv@redhat.com
>I've seen this before but cannot reproduce it with the current driver >(2.4.9-17.4)
>Additional comment by clay_cooper@dell.com
>Reproduced w/ 2.4.9-17.4smp

Does it happen every time now?  If not, can you characterize this?

Comment 4 Arjan van de Ven 2001-12-05 17:12:58 EST
I just tried this 4 times (fdisk /dev/sdX, make partition, mke2fs, mount, put
file on, umount, reboot) and I could mount and read the file just fine after
Comment 5 Michael K. Johnson 2001-12-05 17:35:55 EST
To clarify, our tests were done with a PV650 direct-attached.  We did
the same tests earlier using the switched fabric.  We could not
reproduce the problem with either setup.  Sounds like we need more
explicit setup information; we have duplicated as exactly as we can,
with no luck reproducing it.
Comment 6 Clay Cooper 2001-12-06 11:35:16 EST
Ever since I created partitions, filesystems, and mounted all ten luns on my
attached storage I have not been able to reproduce this.  Several reboots and
different combinations of mounting and rebooted, and still nothing.  I have not
see this since the very first check after installing 2.4.9-17.4smp.  I will keep
an eye out for this, but it appears to be all but gone.
Comment 7 Michael K. Johnson 2001-12-06 11:39:21 EST
So the first boot must have been a leftover from the previous kernel.
I'll close this; re-open it if you see it again with 17.4 or later.

Note You need to log in before you can comment on or make changes to this bug.