Bug 56979 - mkinitrd does not like /tmp on tmpfs
mkinitrd does not like /tmp on tmpfs
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-01 17:38 EST by Michal Jaegermann
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-16 15:26:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to use /var/tmp, with a possible override, in mkinitrd (622 bytes, patch)
2001-12-01 17:40 EST, Michal Jaegermann
no flags Details | Diff

  None (edit)
Description Michal Jaegermann 2001-12-01 17:38:34 EST
Description of Problem:

If tmpfs happens to be used for /tmp then mkinitrd, hence also
mkbootdisk and kernel updates, fail because one cannot, at least
currently, to mount over a loop device a file which resides on a file
system of a tmpfs type.

A quick workaround, which has pretty good chances to work, is it use
/var/tmp instead with a possible override in an evironmental variable.
An attached patch does just that.

Somewhat better would be to allow to specify other then a default
temporary directory on a command line.  But to make this work reasonably
reliably with kernel updates mkinitrd should test if it tries to use
files on tmpfs and switch to another file system if this is the case
(or / could be simply used here as chances that it is of a tmpfs type on
a normal installation are rather slim :-).
Comment 1 Michal Jaegermann 2001-12-01 17:40:20 EST
Created attachment 39304 [details]
Patch to use /var/tmp, with a possible override, in mkinitrd
Comment 2 Erik Troan 2002-01-16 15:26:24 EST
This is fixed in mkinird-3.3.1 properly (in rawhide soon), but I can't seem to
close bugs right now.
Comment 3 Erik Troan 2002-01-16 15:29:43 EST
Galeon better :-)

Note You need to log in before you can comment on or make changes to this bug.