Bug 569823 - SIGSEGV when trying to panelize find results
Summary: SIGSEGV when trying to panelize find results
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mc
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a87fe94f021c09f4b81e19659bd...
: 570540 578778 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-02 14:23 UTC by Jan ONDREJ
Modified: 2013-07-02 23:42 UTC (History)
12 users (show)

Fixed In Version: mc-4.7.1-2.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-01 01:51:53 UTC


Attachments (Terms of Use)
File: backtrace (4.67 KB, text/plain)
2010-03-02 14:23 UTC, Jan ONDREJ
no flags Details
Fixes the crash (941 bytes, patch)
2010-03-02 14:53 UTC, Jindrich Novy
no flags Details | Diff

Description Jan ONDREJ 2010-03-02 14:23:54 UTC
abrt 1.0.7 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/bin/mc -P /tmp/mc-ondrejj/mc.pwd.25588
comment: When trying to panelize onver search results, segmentation error occurs.
component: mc
executable: /usr/bin/mc
kernel: 2.6.31.12-174.2.22.fc12.i686.PAE
package: mc-1:4.7.1-1.fc12
rating: 4
reason: Process /usr/bin/mc was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. F9 -> Command -> Find file
2. Let him to find at least one file.
3. press "l" (panelize)

Comment 1 Jan ONDREJ 2010-03-02 14:23:57 UTC
Created attachment 397334 [details]
File: backtrace

Comment 2 Jan ONDREJ 2010-03-02 14:26:54 UTC
This worked with previous version of mc.

Comment 3 Jindrich Novy 2010-03-02 14:53:27 UTC
Created attachment 397338 [details]
Fixes the crash

A guy who added this:

lc_filename = strchr (le->text + 4, ':') + 1;

to upstream mc needs slapping :) I can hardly imagine worse code.

Comment 4 Jan ONDREJ 2010-03-02 15:45:32 UTC
Please build an update for F12. Thank you.

Comment 5 Slava Zanko 2010-03-02 19:21:39 UTC
Filled into upstream: http://www.midnight-commander.org/ticket/2080

> to upstream mc needs slapping :) I can hardly imagine worse code.
Will be done correctly :)

P.S. You extremally fast with patching... I'm shoked :)

Comment 6 Slava Zanko 2010-03-02 19:59:51 UTC
Hm... Jindrich, please try http://www.midnight-commander.org/changeset/7b9226c5da3a81fb758bee70aafe05bb64d37464

http://www.midnight-commander.org/ticket/2068
I forgotten about same trouble...

Comment 7 Jindrich Novy 2010-03-03 10:38:32 UTC
Slava, good to see it was already fixed upstream :) I can confirm the Andrew's patch fixed it. Thanks for noticing.

In any case the present code is dangerous so we might see such surprises quite often :)

Comment 8 Jindrich Novy 2010-03-03 10:40:25 UTC
Jan, the 4.7.1 mc release is brand new so it is likely that additional bugs will occur. I would delay any F12/F11 updates for a week or two so that we needn't to push partial updates too often.

Comment 9 Slava Zanko 2010-03-03 11:08:28 UTC
> In any case the present code is dangerous so we might see such surprises quite
often :)

Sorry, it's development branch.

> Jan, the 4.7.1 mc release is brand new so it is likely that additional bugs
will occur.

Yup. Jan, try to use 4.7.0-stable branch (latest release is 4.7.0.3). This branch don't contain newly added regressions (but also don't contain newly added features ;) ). Download page: http://rpm.zaytsev.net/mc-releases/mc-4.7.0.3/

Comment 10 Jindrich Novy 2010-03-05 08:03:06 UTC
*** Bug 570540 has been marked as a duplicate of this bug. ***

Comment 11 Doncho Gunchev 2010-03-17 15:06:15 UTC

How to reproduce
-----
1. run mc
2. Command->Find *.py?, OK
3. Panelize


Comment
-----
I was simply trying to find all *.pyo and *.pyc files (*.py?), panelize and remove all of them. I regulary use this so this bug must be recent.

Comment 12 Fedora Update System 2010-03-18 14:53:26 UTC
mc-4.7.1-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/mc-4.7.1-2.fc11

Comment 13 Fedora Update System 2010-03-18 14:56:21 UTC
mc-4.7.1-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/mc-4.7.1-2.fc12

Comment 14 Fedora Update System 2010-03-18 14:58:20 UTC
mc-4.7.1-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/mc-4.7.1-2.fc13

Comment 15 Oleksandr Symonenko 2010-03-18 15:58:20 UTC

How to reproduce
-----
1. search for ".svn" folders (1041 was found)
2. select [Panalize] 
3.


Comment
-----
should be a problem with allocating space when panalizing huge number of files

Comment 16 Fedora Update System 2010-03-23 02:04:29 UTC
mc-4.7.1-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/mc-4.7.1-2.fc12

Comment 17 Fedora Update System 2010-03-23 02:04:51 UTC
mc-4.7.1-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/mc-4.7.1-2.fc11

Comment 18 Fedora Update System 2010-03-23 02:21:04 UTC
mc-4.7.1-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/mc-4.7.1-2.fc13

Comment 19 Maciek 2010-03-23 20:43:24 UTC

How to reproduce
-----
1.F9
2.Command - Find File
3.Panelize on search results

Comment 20 Jindrich Novy 2010-03-24 07:47:00 UTC
Please give positive karma to the updates so that they get pushed into stable.

Comment 21 Fedora Update System 2010-04-01 01:51:43 UTC
mc-4.7.1-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Jindrich Novy 2010-04-01 11:33:47 UTC
*** Bug 578778 has been marked as a duplicate of this bug. ***

Comment 23 Fedora Update System 2010-04-03 04:38:32 UTC
mc-4.7.1-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2010-04-09 03:49:29 UTC
mc-4.7.1-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.