Bug 56994 - "mysterious" errors from pcmcia
"mysterious" errors from pcmcia
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-02 10:54 EST by Michal Jaegermann
Modified: 2015-01-04 17:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 02:10:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-12-02 10:54:25 EST
Description of Problem:

Every restart of pcmcia service drops into logs a line like that:

... cardmgr[754]: config error,
     file './config.opts' line 8: no function bindings

A bit mysterious as the line in question "includes" some port ranges.

Closer investigation reveals that this error is actually in
/etc/pcmcia/config which "sources" config.opts.  The problem is
that that last card stanza, for "Xircom RBM56G Modem", is missing
"bind" line.  As this is a modem my guess would be that this

--- /etc/pcmcia/config~	Mon Sep  3 06:25:42 2001
+++ /etc/pcmcia/config	Sun Dec  2 00:09:55 2001
@@ -1947,6 +1947,7 @@
 
 card "Xircom RBM56G Modem"
   manfid 0x0105, 0x1000
+  bind "serial_cs"
 
 # Include configuration files for add-on drivers
 
applies.

   Michal
   michal@harddata.com

Note You need to log in before you can comment on or make changes to this bug.