Bug 570102 - [abrt] crash in uncaught exception from OSharedConnection::getMetaData (SIGABRT)
Summary: [abrt] crash in uncaught exception from OSharedConnection::getMetaData (SIGABRT)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:699a990292f8d9752526a6b0814...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-03 09:55 UTC by collura
Modified: 2010-03-23 23:36 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-03-23 23:36:41 UTC


Attachments (Terms of Use)
File: backtrace (83.52 KB, text/plain)
2010-03-03 09:55 UTC, collura
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 109766 None None None Never

Description collura 2010-03-03 09:55:02 UTC
abrt 1.0.7 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/openoffice.org3/program/soffice.bin -base
comment: was working in openoffice.org base and had just deleted a form in the database
component: openoffice.org
executable: /usr/lib64/openoffice.org3/program/soffice.bin
kernel: 2.6.31.12-174.2.22.fc12.x86_64
package: openoffice.org-brand-1:3.1.1-19.26.fc12
rating: 4
reason: Process /usr/lib64/openoffice.org3/program/soffice.bin was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

Comment 1 collura 2010-03-03 09:55:05 UTC
Created attachment 397518 [details]
File: backtrace

Comment 2 Caolan McNamara 2010-03-03 11:06:18 UTC
I can't reproduce the exact crash, but I can simulate it by forcing the exception. I see that the other uses of this method catch the exception, while this ones doesn't.

Comment 3 Caolan McNamara 2010-03-03 11:20:53 UTC
Patch to not crash checked in and submitted upstream, fix will be in >= 3.1.1-19.27 if there is another update for F-12

Comment 4 Fedora Update System 2010-03-04 10:36:46 UTC
openoffice.org-3.2.0-12.10.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/openoffice.org-3.2.0-12.10.fc13

Comment 5 Fedora Update System 2010-03-09 03:24:34 UTC
openoffice.org-3.2.0-12.10.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2010-03-17 11:06:13 UTC
openoffice.org-3.1.1-19.28.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.28.fc12

Comment 7 Fedora Update System 2010-03-18 03:27:05 UTC
openoffice.org-3.1.1-19.28.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.28.fc12

Comment 8 Fedora Update System 2010-03-23 23:35:59 UTC
openoffice.org-3.1.1-19.28.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.