Bug 57015 - Ext3 boot fail after crashed ...
Ext3 boot fail after crashed ...
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Tweedie
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-03 05:09 EST by Phattanon Duangdara
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-03 10:10:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phattanon Duangdara 2001-12-03 05:09:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Think it's because RedHat Linux 7.2 (Release default Kernel 2.4.7)
not built-in ext3 driver on kernel, got load from module.

Im expect this error with kernel panic
After my system crashed ad press reset button :

EXT2fs: Filesystem option not supported by kernel
Cannot mount root file system.

This appears every time on boot since crashed.Version-Release number of 
selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Make system crashed, push reset, when reading/writing perform on disk. 
Should try many times on quite slow system and harddisk.

Additional info:
 I've try built in ext3 driver and that can solve this problem.

Sorry if this problem fixed on 2.4.9 update ... I try search bugzilla but not 
found any reports and I haven't upgrade kernel yet.
Comment 1 Arjan van de Ven 2001-12-03 05:14:43 EST
If you use ext3 as module (as the default kernel does) then you must make use of
an initrd (which the default setup also does)....... then it will use ext3
instead of ext2.
Comment 2 Phattanon Duangdara 2001-12-03 05:39:44 EST
I use grub loader when install and this happen without having modified any
grub config or kernel.
Comment 3 Stephen Tweedie 2001-12-03 10:10:13 EST
Did you upgrade to ext3 by hand?  If so, you must create a new initrd ramdisk.

The requirements for booting from a kernel with modular ext3 are:

* You must have an initrd boot ramdisk which is configured to load ext3 (which
means you must create this initrd *after* setting the fs type for the root
filesystem to "ext3" in /etc/fstab), and

* You must instruct the boot loader to load this initrd.

If you upgraded to ext3 during a normal 7.2 upgrade, then the installer should
deal with all of this for you.

This might only be a kernel fault if you did in fact have ext3 loaded at boot
but the kernel still couldn't load the root filesystem, but in that case there
would be extra boot-time log messages indicating a failure to load root inside
ext3.  The only log message you supplied was:

EXT2fs: Filesystem option not supported by kernel

which on its own indicates that this is a configuration problem, not a kernel
problem: the system has not been configured to load ext3 at boot time so the
kernel is trying to load root as ext2 instead.

Note You need to log in before you can comment on or make changes to this bug.