This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 570251 - Notifications sent by some applications cause hangs
Notifications sent by some applications cause hangs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: notification-daemon (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-03 11:58 EST by Sandro Mani
Modified: 2013-03-05 23:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-10 13:28:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Log of dbus messages (125.44 KB, application/octet-stream)
2010-03-03 11:58 EST, Sandro Mani
no flags Details
dbus example from emesene (237.85 KB, text/plain)
2010-04-23 11:01 EDT, Sandro Mani
no flags Details

  None (edit)
Description Sandro Mani 2010-03-03 11:58:55 EST
Created attachment 397611 [details]
Log of dbus messages

Description of problem:
Notifications sent by some application hang the system for some time.

Version-Release number of selected component (if applicable):
notification-daemon-0.4.1-0.20090923.4.fc12.x86_64

How reproducible:
For testcase indicated below, always.

Steps to Reproduce: Testcase:
1. Start firefox
2. Choose a file to download which will take at least 20-30 sec to download, then rightclick the link and choose "Save link as..."
3. File downloads as usual
4. When the "Download Complete" notification should appear, the system hangs instead for 15-20s. Afterward, the notification appears as expected.
  
Actual results:
For the described testcase, as soon as one expects the notification to appear, most or all of the gui widgets are unresponsive, terminal occasionally still grabs keyboard input. Mouse keeps moving, and also applets in the panel get updated (clock, netspeed). Can switch to virtual terminal via CTRL+ALT+F*, there I can write killall notification-daemon and the system returns responsive immediately.

Expected results:
Should not hang. It is possibly the application's fault that it sends "bad" notifications, but this should not cause the whole system to hang.

Additional info:
I managed to narrow down the issue in firefox (both stock 3.58.fc12 as well ass nightly minefield 3.7a3), but it is not the only application that sends "bad" notifications, banshee is another one for instance. On the other hand there are other applications where notifications always work flawlessly, say emesene or even manual /usr/bin/notify-send.
Attached is the dbus log, messages are from the period between when I started the download and until the notification eventually appeared.
Comment 1 Sandro Mani 2010-04-23 11:01:43 EDT
Created attachment 408641 [details]
dbus example from emesene

Some additional information: it appears some applications send the icon which appears in the notification as binary array to the dbus channel. These arrays can often have 10'000 or more entries. Could it be that this amount of data occasionally causes other applications monitoring the dbus channel to hang while they interpret the data? I cannot reproduce the issue sending notifications via notifiy-send -i <icon> ... but on the other hand notifications send this way don't also send the icon in binary on the dbus. Attached is an example of the dbus messages caused by a simple <user sent a message> notification from emesene. (Finally, why would the icons want to get sent over dbus anyway?)
Comment 2 Sandro Mani 2010-05-10 13:28:32 EDT
Never got this issue on F13, closing...

Note You need to log in before you can comment on or make changes to this bug.