Bug 570318 (gnuplot44) - Review Request: gnuplot44 - A program for plotting mathematical expressions and data
Summary: Review Request: gnuplot44 - A program for plotting mathematical expressions a...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: gnuplot44
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mark Chappell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-03 20:54 UTC by Steve Traylen
Modified: 2011-09-18 18:22 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-13 11:24:10 UTC
Type: ---
tremble: fedora-review+
kevin: fedora-cvs+


Attachments (Terms of Use)

Description Steve Traylen 2010-03-03 20:54:09 UTC
This is a strictly EPEL only package. It has been designed to coexist with
out impact to the existing gnuplot-4.0.0 in RHEL5.

Spec URL: http://cern.ch/straylen/rpms/gnuplot42/gnuplot42.spec
SRPM URL: http://cern.ch/straylen/rpms/gnuplot42/gnuplot42-4.2.6-3.el5.src.rpm
Description: 
Gnuplot is a command-line driven, interactive function plotting
program especially suited for scientific data representation.  Gnuplot
can be used to plot functions and data points in both two and three
dimensions and in many different formats.

Comment 1 Thomas Spura 2010-03-03 23:14:55 UTC
Why not just updating the gnuplot version in RHEL?

Comment 2 Rex Dieter 2010-03-04 03:01:58 UTC
Because that's either very difficult or impossible.

Comment 3 Steve Traylen 2010-03-04 06:33:26 UTC
Re comment #1 because of the first item of
 http://fedoraproject.org/wiki/EPEL/GuidelinesAndPolicies#Policy_for_Conflicting_Packages 

which is completely correct.

Comment 5 Mark Chappell 2010-09-11 13:34:39 UTC
 - = N/A
 / = Check
 ! = Problem
 ? = Not evaluated

=== REQUIRED ITEMS ===
 [/] Package is named according to the Package Naming Guidelines.
 [/] Spec file name must match the base package %{name}, in the format
%{name}.spec.
 [/] Package meets the Packaging Guidelines including the Language specific items
 [/] Package successfully compiles and builds into binary rpms on at least one
supported architecture.
     Tested: http://koji.fedoraproject.org/koji/taskinfo?taskID=2461520
 [/] Rpmlint output:
bash-4.1$ rpmlint gnuplot42-*.rpm
gnuplot42.src: W: spelling-error %description -l en_US Gnuplot -> Gnu plot, Gnu-plot, Grassplot
gnuplot42.x86_64: W: spelling-error %description -l en_US Gnuplot -> Gnu plot, Gnu-plot, Grassplot
gnuplot42.x86_64: W: no-documentation
gnuplot42.x86_64: W: no-manual-page-for-binary gnuplot42-wx
gnuplot42-common.x86_64: W: spelling-error %description -l en_US Gnuplot -> Gnu plot, Gnu-plot, Grassplot
gnuplot42-common.x86_64: W: spelling-error %description -l en_US subpackage -> sub package, sub-package, prepackage
gnuplot42-latex.x86_64: W: no-documentation
gnuplot42-minimal.x86_64: W: spelling-error %description -l en_US Gnuplot -> Gnu plot, Gnu-plot, Grassplot
gnuplot42-minimal.x86_64: W: no-documentation
gnuplot42-minimal.x86_64: W: no-manual-page-for-binary gnuplot42-minimal
6 packages and 0 specfiles checked; 0 errors, 10 warnings.
 [/] Package is not relocatable.
 [/] Buildroot is correct  ( Not needed if >= EL6 and >= F13 )
     Buildroot:  %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 [/] Package is licensed with an open-source compatible license and meets other
legal requirements as defined in the legal section of Packaging Guidelines.
 [/] License field in the package spec file matches the actual license.
     License type: gnuplot
 [/] If (and only if) the source package includes the text of the license(s) in
its own file, then that file, containing the text of the license(s) for the
package is included in %doc.
 [!] With any Subpackage installed the license must also be installed (this may
belong to another subpackage)
 [/] Spec file is legible and written in American English.
 [/] Sources used to build the package matches the upstream source, as provided
in the spec URL.
    md5sums of both c10468d74030e8bed0fd6865a45cf1fd
 [/] Package is not known to require ExcludeArch
 [/] All build dependencies are listed in BuildRequires, except for any that
are listed in the exceptions section of Packaging Guidelines.
 [-] The spec file handles locales properly.
 [-] ldconfig called in %post and %postun if required.
 [/] Package must own all directories that it creates.
 [/] Package requires other packages for directories it uses.
 [/] Package does not contain duplicates in %files.
 [/] Permissions on files are set properly.
 [/] Package has a %clean section, which contains rm -fR $RPM_BUILD_ROOT. ( Not
needed if >= EL6 and >= F13 )
 [/] Package consistently uses macros.
 [/] Package contains code, or permissible content.
 [/] Large documentation files are in a -doc subpackage, if required.
 [/] Package uses nothing in %doc for runtime.
 [-] Header files in -devel subpackage, if present.
 [-] Static libraries in -static subpackage, if present.
 [-] Package requires pkgconfig, if .pc files are present.
 [-] Development .so files in -devel subpackage, if present.
 [/] Fully versioned dependency in subpackages, if present.
 [/] Package does not contain any libtool archives (.la).
 [-] Package contains a properly installed %{name}.desktop file if it is a GUI
application.
 [/] Package does not own files or directories owned by other packages.


=== SUGGESTED ITEMS ===
 [!] Latest version is packaged.
 [/] Package does not include license text files separate from upstream.
 [-] Description and summary sections in the package spec file contains
translations for supported Non-English languages, if available.
 [/] Reviewer should test that the package builds in mock.
     Tested through koji
 [/] Package should compile and build into binary rpms on all supported
architectures.
     Tested on: dist-5E-epel-testing-candidate
 [-] Package functions as described.
 [/] Scriptlets must be sane, if used.
 [-] The placement of pkgconfig(.pc) files is correct.
 [-] File based requires are sane.
 [-] %check is present and the tests pass

=== COMMENTS ===

Blocker:
* Please include the license file in all sub packages.

Notes:
* rpmlint warning about selling can  be ignored  
* Version 4.4 is now available

Comment 6 Mark Chappell 2010-09-11 19:06:03 UTC
Actually, don't worry about the license file, all packages without the license file end up pulling in -common which has the license file.

Package approved.

Comment 7 Steve Traylen 2010-09-11 19:48:03 UTC
Thanks, I'd almost forgotten about this one. We've been using it here for ages
and many users are happy with it.

I'll do the upgrade to 44 now and post here in case you have any comment.
Will let you know if there is any significant change other than the upgrade.

Comment 8 Steve Traylen 2010-10-14 08:15:33 UTC
Thanks again for the review.

I've now updated the parralel package to be gnuplot44

http://cern.ch/straylen/rpms/gnuplot42/gnuplot44.spec
http://cern.ch/straylen/rpms/gnuplot42/gnuplot44-4.4.2-2.el5.src.rpm

other than the upstream update there is not really any significant
difference in the package other than being rebased on the current F15 
gnuplot.

I'm confident that the review of gnuplot42 is applicable and relevant
to this new gnuplot44.

I'll leave this package here for a week in case there is comment before
making the git request.

Steve.

Comment 9 Steve Traylen 2010-10-18 17:28:40 UTC
New Package SCM Request
=======================
Package Name: gnuplot44
Short Description: A program for plotting mathematical expressions and data
Owners: stevetraylen
Branches: el4 el5 el6

This an EPEL only build so should/will be retired from Fedora asap.

 Steve.

Comment 10 Kevin Fenzi 2010-10-19 03:56:04 UTC
Git done (by process-git-requests).

Comment 11 Fedora Update System 2010-10-19 15:06:23 UTC
gnuplot44-4.4.2-2.el4 has been submitted as an update for Fedora EPEL 4.
https://admin.fedoraproject.org/updates/gnuplot44-4.4.2-2.el4

Comment 12 Fedora Update System 2010-10-19 15:06:30 UTC
gnuplot44-4.4.2-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/gnuplot44-4.4.2-2.el5

Comment 13 Jose Pedro Oliveira 2010-10-19 21:44:39 UTC
(In reply to comment #8)
> Thanks again for the review.
> 
> I've now updated the parralel package to be gnuplot44
> 
> http://cern.ch/straylen/rpms/gnuplot42/gnuplot44.spec
> http://cern.ch/straylen/rpms/gnuplot42/gnuplot44-4.4.2-2.el5.src.rpm
> 
> other than the upstream update there is not really any significant
> difference in the package other than being rebased on the current F15 
> gnuplot.
> 
> I'm confident that the review of gnuplot42 is applicable and relevant
> to this new gnuplot44.

Famous last words!

The gnuplot 4.4 requirement

   Requires: dejavu-sans-fonts

can't be fulfilled for EL-{4,5} (only for EL6).

Comment 14 Jose Pedro Oliveira 2010-10-20 12:56:14 UTC
The EL4 and EL5 packages

 * https://admin.fedoraproject.org/updates/gnuplot44-4.4.2-2.el5

 * https://admin.fedoraproject.org/updates/gnuplot44-4.4.2-2.el4

have now negative karma.

Comment 15 Fedora Update System 2010-10-20 16:30:47 UTC
gnuplot44-4.4.2-2.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnuplot44'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gnuplot44-4.4.2-2.el4

Comment 16 Steve Traylen 2011-03-13 11:24:10 UTC
I'm just going to live with gnuplot versions in RHEL6 and ignore RHEL4 and 5.

Steve.


Note You need to log in before you can comment on or make changes to this bug.