Bug 57042 - pine doesn't use KDE (or gnome) konsole colors
Summary: pine doesn't use KDE (or gnome) konsole colors
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: pine   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-03 18:33 UTC by Rex Dieter
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-29 18:19:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rex Dieter 2001-12-03 18:33:12 UTC
In all versions of pine up to and including version 4.43, the default 
/etc/pine.conf has
# Controls display of color
color-style=use-termdef

which makes it ignore configured terminal color schemes in KDE's konsole 
or GNOME's terminal.  

The easiest fix I found was setting it to
color-style=
, which makes it correctly respect the user's redefined terminal color 
scheme(s).

Comment 1 Mike A. Harris 2002-02-10 02:48:38 UTC
This setting may change the way PINE works by default for some users in
ways that I am not likely to encounter during normal testing.  I've
learned from past experience that changing things like this results in
many users discovering something no longer works how they are used to
it working by default, and so I am hesitant to make such a change.

Personally I dont think this level of customization fits into the
realm of general distro setup.  It is and should be a user customization
IMHO, and as I said above, changing things like this without knowing
how it affects every user on every oddball terminal out there, is
just not worth it for something that can be tweaked by those minority
of users who prefer it.

Sorry.

Comment 2 Rex Dieter 2002-02-10 22:29:13 UTC
For what it's worth, there was a time, though I don't remember how far back it 
was (v3.96?), that 
color-style=
WAS the default.  Somewhere in the 4.x.x series, this changed.  I was 
mentioning it here only because pine's behavior had changed at some point, and 
I had received complaints from our users.


Note You need to log in before you can comment on or make changes to this bug.