Bug 570522 - [abrt] crash in gnome-dvb-daemon-0.1.14-4.fc13: Process /usr/bin/gnome-dvb-daemon was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in gnome-dvb-daemon-0.1.14-4.fc13: Process /usr/bin/gnome-dvb-da...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-dvb-daemon
Version: rawhide
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:55d86285bdba225ba8cfdeed964...
: 571168 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-04 16:09 UTC by Bruce Cowan
Modified: 2010-07-07 21:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-07 21:15:12 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (15.54 KB, text/plain)
2010-03-04 16:09 UTC, Bruce Cowan
no flags Details

Description Bruce Cowan 2010-03-04 16:09:19 UTC
abrt 1.0.8 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/bin/gnome-dvb-daemon
comment: This was using a af9015.
component: gnome-dvb-daemon
executable: /usr/bin/gnome-dvb-daemon
kernel: 2.6.33-1.fc13.i686
package: gnome-dvb-daemon-0.1.14-4.fc13
rating: 4
reason: Process /usr/bin/gnome-dvb-daemon was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Rawhide)

How to reproduce
-----
1. Run gnome-dvb-setup
2. Do all the steps in the assistant
3. Click "close" on the last page

Comment 1 Bruce Cowan 2010-03-04 16:09:22 UTC
Created attachment 397842 [details]
File: backtrace

Comment 2 Bastien Nocera 2010-03-09 10:42:06 UTC
*** Bug 571168 has been marked as a duplicate of this bug. ***

Comment 3 Bastien Nocera 2010-03-09 10:42:47 UTC
Please test with gnome-dvb-daemon 0.1.15 that just got uploaded (should land in updates-testing for F-13 shortly).

Comment 4 Peter Robinson 2010-03-09 19:31:48 UTC
Grabbed it from koji as I'm somewhat impatient :-)

It doesn't seem to crash now but I still get no TV.

If I select "Watch TV" from the Movie menu I get the busy cursor for a while then nothing. If I select "Digital TV" from the side bar drop down I get "digital terrestrial TV" and a channel list (which was generated previously with 0.1.14 before it would crash). If I double click on "BBC ONE" for example I then get after a wait a error dialog with "could not open resource for reading and writing"

Comment 5 Bastien Nocera 2010-05-27 12:39:39 UTC
Please test with gnome-dvb-daemon-0.1.18-1.fc13, which fixes a lot of crasher bugs.

Comment 6 Peter Robinson 2010-05-30 08:48:48 UTC
Big improvements with 0.1.19. I actually saw TV :-) but then it stopped with the following error

** Message: Error: pa_stream_writable_size() failed: Connection terminated
pulsesink.c(1388): gst_pulseringbuffer_commit (): /GstPlayBin2:play/GstPlaySink:playsink0/GstBin:abin/GstBin:audiosinkbin/GstGConfAudioSink:audio-sink/GstBin:bin2/GstAutoAudioSink:autoaudiosink1/GstPulseSink:autoaudiosink1-actual-sink-pulse

Although I think this is something else in totem rather than gnome-dvb-daemon so likely not this bug

Comment 7 Bruce Cowan 2010-06-04 01:39:24 UTC
Also works here with no problems.

Comment 8 Peter Robinson 2010-07-07 21:15:12 UTC
Closing errata as it now seems to be fixed :-)


Note You need to log in before you can comment on or make changes to this bug.