Bug 57053 - Textures fails to load on G200/8MB using GLX.
Textures fails to load on G200/8MB using GLX.
Product: Red Hat Linux
Classification: Retired
Component: Mesa (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2001-12-03 15:36 EST by Jiri =BATi= Novak
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-03-12 03:48:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
XFree config file (3.71 KB, text/plain)
2002-01-18 04:05 EST, Jiri =BATi= Novak
no flags Details
XFree log file after startup & running texdown. (25.10 KB, text/plain)
2002-01-18 04:07 EST, Jiri =BATi= Novak
no flags Details

  None (edit)
Description Jiri =BATi= Novak 2001-12-03 15:36:30 EST
Description of Problem:
Any textures using OpenGL app fails to upload textures giving following error 

Failed to upload texture, sz 131072
Memory heap (nil):
  heap == 0
End of memory blocks

but continues to run, resulting in garbage textures being displayed. I have 
never had similiar problems with same config, same resolution and same bit 
depth before upgrading to RH 7.2. Tried to change resolution/bitdepth with no 
I did selected Mesa component, but I suspect problem could be in the 
XFree/GLX guts aswell...

Version-Release number of selected component (if applicable):
GL_VENDOR = VA Linux Systems Inc.
GL_VERSION = 1.2 Mesa 3.4.2
GL_RENDERER = Mesa DRI G200 20010321 AGP 1x x86/MMX

How Reproducible:

Steps to Reproduce:
1. run any OpenGL app using textures.

Actual Results:
error message, garbaged textures

Expected Results:
no messages and nice textures :)

Additional Information:
My current HW config did not change between upgrades - Celeron/333, 128MiB 
RAM, Matrox G200/8MiB.
Comment 1 Mike A. Harris 2002-01-18 03:29:54 EST
Please attach config file and X server log using the file
attachment link below.
Comment 2 Jiri =BATi= Novak 2002-01-18 04:05:03 EST
Created attachment 42794 [details]
XFree config file
Comment 3 Jiri =BATi= Novak 2002-01-18 04:07:47 EST
Created attachment 42795 [details]
XFree log file after startup & running texdown.
Comment 4 Jiri =BATi= Novak 2002-02-01 06:04:14 EST
After applying latest updates (Mesa, XFree86, kernel) via up2date I see no change
in behavior on my machine. Still no go for textures :( I am pretty disappointed,
because release notes stated bugfixes in DRI and I desperately need OpenGL to continue
my work. Why am I only person with this problem? :(

Comment 5 Alexei Podtelezhnikov 2002-02-01 15:00:16 EST
8 MiB is not enough to use DRI at your maximal 1152x864x16bpp, especially with 
textures eating up the memory even more. Do you have the same problem at _all_ 
of your resolutions? I'm not sure how it works, but, maybe, you should try with 
the only "800x600" specified in the XF86Config-4.
Comment 6 Mike A. Harris 2002-02-01 17:29:33 EST
This problem will not be fixed until it is fixed in the upstream Mesa
release.  The Mesa update is _purely_ a syncronization between XFree86
and Mesa - as the packages are married together.  That means that any
XFree86 update, will come with a Mesa update as well.  That Mesa update
may contain no bugfixes at all.  In the case of this particular Mesa
update, it contained one or two trivial bugfixes that were obvious

DRI is not OpenGL.  The DRI bugfixes in the new release, are bugfixes
in the DRM (kernel portion of DRI) for many chipsets.

If I understand correctly, there are some texture related bugs fixed
in the upstream Mesa 4.0 codebase.  These changes are not backportable
to the 3.x series, and Mesa 4 is not ready for primetime stable mass
distribution by Linux vendors due to instabilities, etc.

We do not have in-house 3D experts, and as such, we rely on the Mesa
development team to fix problems such as this which require in depth
knowledge of Mesa and OpenGL.

If the problem is fixed in Mesa 4, it will appear in the distribution
when we ship Mesa 4, however we have no plans currently to ship Mesa 4,
until it is integrated into XFree86 by XFree86.org.

Since you've indicated this is an issue with being able to continue
your work, my best suggestion, is that DRI being important for your
work, you might consider upgrading your video card to one that is
better supported and known to work.  A new Radeon 64DDR card is
pretty cheap (approx $100) and that $100 can be quite justified to
any employer if it allows you to do work you would be otherwise
unable to accomplish.

I'm defering this bug report, since it is unlikely to be fixed in one
of our releases any time soon.  When a fix is believed to be available,
I will reopen the report and update it.  I apologize for not being
able to be much more helpful than this.

Also - just a note..  you put the bug in the MODIFIED bug state, which
is a state used by us developers to indicate "bug believed to be fixed,
but is untested yet either due to lack of hardware, or some other
reason, and requires reporter or someone else to confirm if it is fixed
or not".  I just caught it with my eye, or I probably would never have
seen this report request.  Just thought I'd let you know so you dont
accidentally close other reports you may have filed.

Take care.

Note You need to log in before you can comment on or make changes to this bug.