Bug 570558 - [abrt] crash in firefox-3.5.8-1.fc12: Process /usr/lib64/firefox-3.5.8/firefox was killed by signal 6 (SIGABRT)
Summary: [abrt] crash in firefox-3.5.8-1.fc12: Process /usr/lib64/firefox-3.5.8/firefo...
Status: CLOSED DUPLICATE of bug 546155
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:325e2c57d0c8cdfb5ba5a15c53b...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-04 17:56 UTC by Brandon Stimmel
Modified: 2010-03-07 14:40 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-03-07 14:40:25 UTC


Attachments (Terms of Use)
File: backtrace (39.82 KB, text/plain)
2010-03-04 17:56 UTC, Brandon Stimmel
no flags Details

Description Brandon Stimmel 2010-03-04 17:56:04 UTC
abrt 1.0.7 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/firefox-3.5.8/firefox
comment: just saw this in my bug reporting tool, figured I'd send it.
component: firefox
executable: /usr/lib64/firefox-3.5.8/firefox
kernel: 2.6.31.12-174.2.22.fc12.x86_64
package: firefox-3.5.8-1.fc12
rating: 4
reason: Process /usr/lib64/firefox-3.5.8/firefox was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. not sure
2.
3.

Comment 1 Brandon Stimmel 2010-03-04 17:56:06 UTC
Created attachment 397884 [details]
File: backtrace

Comment 2 Chris Campbell 2010-03-07 14:31:31 UTC
#5  0x00000036bceba2cd in __gnu_cxx::__verbose_terminate_handler ()
    at ../../../../libstdc++-v3/libsupc++/vterminate.cc:93
        terminating = true
        t = <value optimized out>
#6  0x00000036bceb8456 in __cxxabiv1::__terminate (
    handler=<value optimized out>)
    at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:38
No locals.
#7  0x00000036bceb8483 in std::terminate ()
    at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:48
No locals.
#8  0x00000036bceb8daf in __cxxabiv1::__cxa_pure_virtual ()
    at ../../../../libstdc++-v3/libsupc++/pure.cc:50
No locals.
#9  0x000000329b0ce897 in canonicalize (in=0x7fec25cf8830)
    at nsCycleCollector.cpp:1161
        child = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
#10 0x000000329b0ceaa8 in GCGraphBuilder::NoteXPCOMChild (
    this=0x7fffae9703d0, child=<value optimized out>)
    at nsCycleCollector.cpp:1450
        cp = <value optimized out>
#11 0x000000329a89bd15 in XPCWrappedNative::cycleCollection::Traverse (
    this=<value optimized out>, p=0x7fec2726f580, cb=...)
    at xpcwrappednative.cpp:105
        tmp = 0x7fec2726f580
#12 0x000000329b0ce6c1 in GCGraphBuilder::Traverse (this=0x6, 
    aPtrInfo=0x7fec33a355c8) at nsCycleCollector.cpp:1375
        rv = <value optimized out>
#13 0x000000329b0ce73b in nsCycleCollector::MarkRoots (
    this=<value optimized out>, builder=...) at nsCycleCollector.cpp:1574
        pi = <value optimized out>
#14 0x000000329b0ceeea in nsCycleCollector::BeginCollection (
    this=0x7fec3557f000) at nsCycleCollector.cpp:2507
        builder = {<nsCycleCollectionTraversalCallback> = {
            _vptr.nsCycleCollectionTraversalCallback = 0x329b9801a0}, 
          mNodeBuilder = {mNextBlock = 0x7fec33a00000, 
            mNext = @0x7fec3557f078, mBlockEnd = 0x7fec33b40008}, 
          mEdgeBuilder = {mCurrent = 0x7fec33f732b0, 
            mBlockEnd = 0x7fec33fccff0, mNextBlockPtr = 0x7fec33fccff8}, 
          mPtrToNodeMap = {ops = 0x329b9a96e0, data = 0x0, hashShift = 17, 
            maxAlphaFrac = 192 '\300', minAlphaFrac = 64 '@', entrySize = 16, 
            entryCount = 10108, removedCount = 0, generation = 0, 
            entryStore = 0x7fec24061000 "\350w\367\273"}, 
          mCurrPi = 0x7fec33a355c8, mRuntimes = 0x7fec3557f010}
#15 0x000000329a87f646 in XPCCycleCollectGCCallback (cx=0x7fec25f28400, 
    status=JSGC_MARK_END) at nsXPConnect.cpp:390
No locals.




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Chris Campbell 2010-03-07 14:40:25 UTC
Thank you for taking the time to submit this bug report.

This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 546155 ***


Note You need to log in before you can comment on or make changes to this bug.