Bug 570562 - Fedora 13 still has the dirsrv/slapd labeling conflict
Summary: Fedora 13 still has the dirsrv/slapd labeling conflict
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 13
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 570333 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-04 17:59 UTC by Rich Megginson
Modified: 2010-03-10 06:48 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-03-10 06:48:38 UTC


Attachments (Terms of Use)

Description Rich Megginson 2010-03-04 17:59:33 UTC
[root@f13x8664 ~]# semodule -v -s targeted -i /usr/share/selinux/targeted/dirsrv.pp 
Attempting to install module '/usr/share/selinux/targeted/dirsrv.pp':
Ok: return value of 0.
Committing changes:
/etc/selinux/targeted/contexts/files/file_contexts: Multiple different specifications for /usr/sbin/ns-slapd  (system_u:object_r:slapd_exec_t:s0 and system_u:object_r:dirsrv_exec_t:s0).
/etc/selinux/targeted/contexts/files/file_contexts: Invalid argument
libsemanage.semanage_install_active: setfiles returned error code 1.
semodule:  Failed!

This is with selinux-policy 3.7.10-4.fc13

Fedora 12 fixed this problem https://admin.fedoraproject.org/updates/F12/FEDORA-2010-2953
# Tue Feb 23 2010 Miroslav Grepl <mgrepl@redhat.com> 3.6.32-92
...
# Remove label for Directory Server 
559298 - SELinux is preventing /usr/sbin/smbd "connectto" access on /var/run/slapd-*.socket

We need the same fix in F-13

Comment 1 Rich Megginson 2010-03-04 18:00:28 UTC
Increasing priority because this prevents installing 389 on Fedora 13.

Comment 2 Rich Megginson 2010-03-04 18:02:25 UTC
*** Bug 570333 has been marked as a duplicate of this bug. ***

Comment 3 Daniel Walsh 2010-03-04 18:21:39 UTC
Fixed in selinux-policy-3.7.11-1.fc13.noarch

Comment 4 Fedora Update System 2010-03-04 18:46:52 UTC
selinux-policy-3.7.11-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/selinux-policy-3.7.11-1.fc13

Comment 5 Fedora Update System 2010-03-05 03:34:44 UTC
selinux-policy-3.7.11-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.7.11-1.fc13

Comment 6 Fedora Update System 2010-03-10 06:48:12 UTC
selinux-policy-3.7.11-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.