Bug 57066 - samba compilation error: redefinition of struct statfs
Summary: samba compilation error: redefinition of struct statfs
Status: CLOSED DUPLICATE of bug 55727
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba   
(Show other bugs)
Version: 7.2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-04 02:58 UTC by Need Real Name
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-04 02:58:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-12-04 02:58:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686; Nav)

Description of problem:
I got the following error when compiling samba2.2.2 no matter what
configuration I used:
	Please see "Actuctual Results" below.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.configure samba2.2.2 to produce the Makefile using none or any options
2.type make
3.
	

Actual Results:  Compiling smbd/server.c
In file included from /usr/include/linux/vfs.h:4,
		 from /usr/include/linux/fs.h:14,
		 from /usr/include/linux/capability.h:17,
		 from /usr/include/sys/capanility.h:24,
		 from include/includes.h:333,
		 from smbd/server.c:22
/usr/include/asm/statfs.h:12 redefinition of 'struct statfs'
make: ***[smbd/server.o] Eror 1

Expected Results:  Make successfully

Additional info:

I also noticed that /usr/include/asm/statfs.h and /usr/include/bits/
statfs.h both define 'struct statfs' but the definition of the fields are
different. /usr/include/bits/statfs.h is used by /usr/include/sys/statfs.h
which is used by samba include/includes.h.

Comment 1 Trond Eivind Glomsrxd 2001-12-04 16:10:45 UTC

*** This bug has been marked as a duplicate of 55727 ***


Note You need to log in before you can comment on or make changes to this bug.