Bug 57067 - single user mode does not stop all the processes that it should
single user mode does not stop all the processes that it should
Status: CLOSED DUPLICATE of bug 54741
Product: Red Hat Linux
Classification: Retired
Component: SysVinit (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-03 23:30 EST by Need Real Name
Modified: 2014-03-16 22:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-07 10:44:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This patch fixes the problem of the parent shell not being killed (cut from halt) should be applied to /etc/init.d/single (548 bytes, patch)
2001-12-07 00:31 EST, Need Real Name
no flags Details | Diff

  None (edit)
Description Need Real Name 2001-12-03 23:30:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011014

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Login as root
2. Run the command "init 1"
	

Actual Results:  Several processes that should have been killed were not. 
Examples are lpd, smbd, nmbd.  The processes that are not killed seems to
vary however, every time two shells seem to be running attached to the same
tty.  When entering commands the first character of the command seems to be
passed to one shell and the remainder to the other shell.

Expected Results:  All K* scripts in /etc/rc.d/rc1.d should have been run
and all coresponding processes should have been stopped.  The user should
be dropped to a shell prompt.  Only one shell should be running.

Additional info:
Comment 1 Need Real Name 2001-12-07 00:31:40 EST
Created attachment 40007 [details]
This patch fixes the problem of the parent shell not being killed (cut from halt) should be applied to /etc/init.d/single
Comment 2 Need Real Name 2001-12-07 10:44:36 EST
This problem only appears after applying the latest errata for 7.2.

I was wrong about services not being stopped - The only problem is that a shell
is left running and is attached to the same tty as the single user shell.  Some
characters go to one shell and some go to the other.
Comment 3 Bill Nottingham 2001-12-13 12:32:46 EST
This should be fixed with the 2.11f-17 util-linux errata.

*** This bug has been marked as a duplicate of 54741 ***

Note You need to log in before you can comment on or make changes to this bug.