Bug 570683 - libvnc.so will not load
libvnc.so will not load
Status: CLOSED DUPLICATE of bug 529295
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-04 20:53 EST by Rick Stevens
Modified: 2013-04-30 19:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-05 04:42:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Stevens 2010-03-04 20:53:41 EST
Description of problem:
libvnc.so will not load on X server blocking use of remote VNC viewer

Version-Release number of selected component (if applicable):
tigervnc-server-module-1.0.0-3.fc12.x86_64

How reproducible:
Consistent

Steps to Reproduce:
1. Add 'Load  "vnc"' to /etc/X11/xorg.conf
2. Restart X or reboot the server
3. Try to connect to it via vncviewer from another machine
  
Actual results:
Connection rejected because vnc.so wasn't loaded

Expected results:
Connection accepted

Additional info:
Scanning /var/log/Xorg.0.log reveals:

(II) LoadModule: "vnc"
(II) Loading /usr/lib64/xorg/modules/extensions/libvnc.so
dlopen: /usr/lib64/xorg/modules/extensions/libvnc.so: undefined symbol: CoreDevicePrivateKey
(EE) Failed to load /usr/lib64/xorg/modules/extensions/libvnc.so
(II) UnloadModule: "vnc"
(EE) Failed to load module "vnc" (loader failed, 7)
Comment 1 Rick Stevens 2010-03-04 20:56:06 EST
Forgot to mention target machine is running the noveau driver:

(II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
(II) Module nouveau: vendor="X.Org Foundation"
        compiled for 1.7.4, module version = 0.0.10
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 6.0

The chipset is:

(--) NOUVEAU(0): Chipset: "NVIDIA NVAA"
Comment 2 Adam Tkac 2010-03-05 04:42:45 EST

*** This bug has been marked as a duplicate of bug 529295 ***

Note You need to log in before you can comment on or make changes to this bug.