Bug 570715 - Publican packages hidden files and directories and temporary files
Publican packages hidden files and directories and temporary files
Status: CLOSED ERRATA
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-05 01:22 EST by Ruediger Landmann
Modified: 2010-11-23 23:16 EST (History)
4 users (show)

See Also:
Fixed In Version: publican-1.6.1-0.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-23 20:46:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SRPM including .svn and .xml~ files (517.63 KB, application/x-rpm)
2010-03-05 01:22 EST, Ruediger Landmann
no flags Details

  None (edit)
Description Ruediger Landmann 2010-03-05 01:22:05 EST
Created attachment 397981 [details]
SRPM including .svn and .xml~ files

Description of problem:

When packaging brands, Publican includes hidden files (like .directory), hidden directories (like .svn) and temporary files (like .xml~). The resulting srpms therefore show warnings in rpmlint and warnings and errors in rpmlint.



Version-Release number of selected component (if applicable):
1.5

How reproducible:
100%

Steps to Reproduce:
1. create a brand and check it into a svn repo; leave some .xml~ files lying around; include a .directory file (file browser metadata for KDE)
2. package the brand
3. run rpmlint on the SRPM and RPM
  
Actual results:
rpmlint reports warnings and errors because of temporary and hidden files

Expected results:
Publican excludes hidden files and directories and temporary files when packaging brands, therefore no warnings and errors in rpmlint.

Additional info:
I haven't noticed temporary files getting packaged with books, but have not specifically tested this yet.
Comment 1 Ruediger Landmann 2010-03-05 01:23:20 EST
Sorry -- the description should read

"The resulting srpms therefore show warnings in rpmlint and *the rpms* show warnings and errors in rpmlint."
Comment 2 Ruediger Landmann 2010-03-22 02:22:21 EDT
Verified fixed for 1.6.1
Comment 3 Fedora Update System 2010-03-23 20:13:07 EDT
publican-1.6.1-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.6.1-0.fc12
Comment 4 Fedora Update System 2010-03-23 20:13:42 EDT
publican-1.6.1-0.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/publican-1.6.1-0.fc11
Comment 5 Fedora Update System 2010-03-23 20:14:11 EDT
publican-1.6.1-0.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/publican-1.6.1-0.fc13
Comment 6 Fedora Update System 2010-03-23 20:46:26 EDT
publican-1.6.1-0.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2010-03-24 19:36:01 EDT
publican-1.6.1-0.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2010-03-24 19:37:41 EDT
publican-1.6.1-0.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.