Bug 570726 - Guest failed to continue to run on source host if 'exec' migration failed due to invalid path
Guest failed to continue to run on source host if 'exec' migration failed due...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Juan Quintela
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-03-05 02:55 EST by Yolkfull Chow
Modified: 2013-01-09 17:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-16 03:19:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yolkfull Chow 2010-03-05 02:55:32 EST
Description of problem:
Specify a invalid path during migration via 'exec' protocol will cause guest hang 
though 'info status' shows it's running.
Issue 'stop' and 'continue' cannot get it back as well.

Version-Release number of selected component (if applicable):
kvm-83-160.el5

How reproducible:
Everytime

Steps to Reproduce:
1. boot the guest
2. issue migration in monitor: 
migrate "exec: gzip -c > /path/not/exists/mem_state.gz"

3. guest hang
  
Actual results:
guest hang and failed to continue run on source host upon migration failure

Expected results:
guest should survive to continue to run on source host

Additional info:
Comment 3 RHEL Product and Program Management 2011-01-11 15:11:24 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2011-01-11 17:50:14 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 5 Dor Laor 2011-01-16 03:19:14 EST
While it is a true bug, it is too low priority to fix.

Note You need to log in before you can comment on or make changes to this bug.