Bug 570796 - Backport drbd support from 2.6.33 kernel
Backport drbd support from 2.6.33 kernel
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Tom Coughlan
Red Hat Kernel QE team
:
Depends On: 666005
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-05 07:44 EST by dijuremo
Modified: 2011-02-09 13:42 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-09 13:42:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dijuremo 2010-03-05 07:44:31 EST
Description of problem:
drbd (a distributed replicated block device) has been included in the linux kernel as of 2.6.33

http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.33

commit 456eac94789e1b512515e6974e091ef655f343de
Merge: dedd0c2 f06f135
Author: Linus Torvalds <torvalds@linux-foundation.org>
Date:   Thu Jan 21 07:32:11 2010 -0800

    Merge branch 'for-linus' of git://git.kernel.dk/linux-2.6-block
    
    * 'for-linus' of git://git.kernel.dk/linux-2.6-block:
      fs/bio.c: fix shadows sparse warning
      drbd: The kernel code is now equivalent to out of tree release 8.3.7
      drbd: Allow online resizing of DRBD devices while peer not reachable (needs to be explicitly forced)
      drbd: Don't go into StandAlone mode when authentification failes because of network error

It would be very useful if it is added to RHEL 5.X and RHEL 6 as well as the userland tools, such already seems to exist for Fedora Core 12, see 

https://bugzilla.redhat.com/show_bug.cgi?id=527488
Comment 4 Ray Van Dolson 2010-04-28 14:55:16 EDT
You'll definitely want to file an RFE SR for this as well.

Do we need a separate bz for RHEL6?
Comment 5 dijuremo 2010-04-29 13:11:24 EDT
Our people with support contracts have opened SR #2017020
Comment 6 Alexander Lindqvist 2010-07-22 09:51:57 EDT
+1. Please add DRBD support to RHEL5. We use it in production on several servers.
Comment 7 Tom Coughlan 2011-02-09 13:42:22 EST
Linbit/DRBD hs been added to the Red Hat Partner Center:

https://www.redhat.com/wapps/partnerlocator/web/home.html#productId=60400

Red Hat will partner with Linbit to provide DRBD support, rather than include it directly in RHEL 5 (or RHEL 6). 

Tom

Note You need to log in before you can comment on or make changes to this bug.