Bug 57087 - TB Conf:472:__delitem__
TB Conf:472:__delitem__
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks: rcn-7.3
  Show dependency treegraph
 
Reported: 2001-12-04 12:45 EST by Michal Jaegermann
Modified: 2015-03-04 20:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-09 10:29:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-12-04 12:45:18 EST
Description of Problem:

An attempt to use "Internet Configuration Wizzard" from a menu
in order to add a ppp connection ended up with the following
traceback:

Traceback (innermost last):
  File "/usr/sbin/internet-druid", line 1206, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/DialupDruid.py",
line 126, in on_finish_page_finish
    self.save()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/InterfaceCreator.py",
line 44, in save
    self.saveProfiles()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/InterfaceCreator.py",
line 56, in saveProfiles
    profilelist.save()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/NCProfileList.py",
line 273, in save
    del hoconf[i]
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line
472, in __delitem__
    del self.vars[varname]
KeyError: 192.168.23.242

Local variables in innermost frame:
self: <netconfpkg.Conf.ConfEHosts instance at 852fd98>
varname: 192.168.23.242

This is on a laptop which does have an ethernet card and is configured
to operate on an internal network but still needs an option of extra
ppp connections.

The bomb happened when all basic data were already typed in and post-mortem
examination revealed that various files, obviously associated with
this configuration attempt, were already written in variouos subdirectories
of /etc/sysconfig/ but I have no way to asses how complete that was.
Enough to make "Dialup Configuration Tool", i.e. rp3-config, deeply
unhappy on a subsequent attempt to configure the same connection again
but not enough to make these leftovers available for edit in rp3-config
(which, BTW, looks like a serious rp3-config bug).  It would be likely
better to have one tool which does the job then two where none seems
to be really up to the task and which conflict with each other.

It is also not really clear what to do to have a default route switched
to ppp connection when it is going up and restored to the previous
state afterwards; or, if you have a vague idea what routing is, that
such need may arise at all.
Comment 1 Harald Hoyer 2002-02-20 07:11:56 EST
hmm, strange. Could you please attach your /etc/hosts???
Comment 2 Michal Jaegermann 2002-02-20 10:43:19 EST
>  Could you please attach your /etc/hosts???

Mine are probably not that interesting and the laptop in question is
on another continent for quite a while and likely reconfigured already
few times. :-)

I will try to reproduce if an opportunity will arise.
Comment 3 Trond Eivind Glomsrxd 2002-07-11 11:45:38 EDT
Haven't seen this since then, so I'm pretty sure this has been fixed. Reopen if
still a problem in limbo or newer.
Comment 4 Harald Hoyer 2002-10-23 05:54:43 EDT
first beta of erratum is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.1-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.1 version... Thx
and please test.

Note You need to log in before you can comment on or make changes to this bug.