Bug 570873 - SELinux is preventing /usr/libexec/gdm-session-worker "read write" access on .xsession-errors.
Summary: SELinux is preventing /usr/libexec/gdm-session-worker "read write" access ...
Keywords:
Status: CLOSED DUPLICATE of bug 543970
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:5650d464575...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-05 18:27 UTC by Matt
Modified: 2010-03-28 18:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-05 18:52:56 UTC


Attachments (Terms of Use)

Description Matt 2010-03-05 18:27:20 UTC
Summary:

SELinux is preventing /usr/libexec/gdm-session-worker "read write" access on
.xsession-errors.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by gdm-session-wor. It is not expected that this
access is required by gdm-session-wor and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                .xsession-errors [ file ]
Source                        gdm-session-wor
Source Path                   /usr/libexec/gdm-session-worker
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gdm-2.28.2-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-92.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31.12-174.2.22.fc12.i686 #1 SMP Fri Feb 19
                              19:26:06 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Fri 05 Mar 2010 06:26:45 PM GMT
Last Seen                     Fri 05 Mar 2010 06:26:45 PM GMT
Local ID                      fd951bc5-4401-460d-ba3b-2bb1166793d2
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1267813605.17:23713): avc:  denied  { read write } for  pid=1615 comm="gdm-session-wor" name=".xsession-errors" dev=dm-0 ino=4632 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1267813605.17:23713): arch=40000003 syscall=33 success=yes exit=0 a0=82541c8 a1=6 a2=d191a4 a3=82541c8 items=0 ppid=1596 pid=1615 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="gdm-session-wor" exe="/usr/libexec/gdm-session-worker" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gdm-session-wor,xdm_t,admin_home_t,file,read,write
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t admin_home_t:file { read write };

Comment 1 Daniel Walsh 2010-03-05 18:52:56 UTC
Root login via X is not supported.

*** This bug has been marked as a duplicate of bug 543970 ***


Note You need to log in before you can comment on or make changes to this bug.