Bug 570929 - Usage of the 5.3.1 version is either too specific or wrong in certain situations.
Summary: Usage of the 5.3.1 version is either too specific or wrong in certain situati...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Documentation
Version: 530
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: John Ha
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: sat531-docs
TreeView+ depends on / blocked
 
Reported: 2010-03-05 21:16 UTC by Brandon Perkins
Modified: 2014-08-04 22:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-17 12:52:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0413 normal SHIPPED_LIVE Red Hat Network Satellite bug fix update 2010-05-17 12:50:51 UTC

Description Brandon Perkins 2010-03-05 21:16:48 UTC
Description of problem:
Usage of the 5.3.1 version is either too specific or wrong in certain situations.

Version-Release number of selected component (if applicable):
rhn-i18n-guides-5.3.0.12-1.el4sat
satellite-doc-indexes-5.3.19-1.el4sat


How reproducible:
Always.

There are a handful of pages with these problems, they didn't seem worthy of their own bugs, so throwing them all together in this one:

== https://rlx-3-14.rhndev.redhat.com/rhn/help//reference/en-US/s1-sm-your-rhn.jsp ==
=== 7.3.4.1. System Entitlements ===
Red Hat Network 5.3.1 allows you to apply and remove entitlements at will

should probably just be:

Red Hat Network Satellite allows you to apply and remove entitlements at will


== https://rlx-3-14.rhndev.redhat.com/rhn/help//reference/en-US/ch-multiorg.jsp ==
=== 9.1.  Recommended Models for Using Multiple Organizations ===
Installing or upgrading to RHN Satellite 5.3.1 does not require that you make use of the multi-org feature.

should probably be:

Installing or upgrading to RHN Satellite 5.1 or later does not require that you make use of the multi-org feature.

as Multi-Org was introduced in 5.1, not 5.3 or 5.3.1.

== https://rlx-3-14.rhndev.redhat.com/rhn/help//satellite/en-US/s1-summary-steps.jsp ==
=== 1.5. Summary of Steps ===
# Log into the RHN website (rhn.redhat.com) and download the distribution ISOs for Red Hat Enterprise Linux AS 4 or Red Hat Enterprise Linux 5 and RHN Satellite 5.3.1.
and
# Install Red Hat Enterprise Linux and then RHN Satellite 5.3.1 on the Satellite machine. 

should just have the 5.3.1 version removed as there is nothing version specific in these two statements.

== https://rlx-3-14.rhndev.redhat.com/rhn/help//proxy/rhn530/en-US/ch-requirements.jsp ==
=== Chapter 2. Requirements ===
To install RHN Proxy Server 5.3.0 from RHN Satellite Server, the Satellite itself must be version 5.3.1. 

this one is a bit more interesting, as there is legitimate reason for the version information to be here.  We can either keep the versions in place, and just knock the 5.3.1 down to 5.3.0 (which would be correct).  Or, we can make a more generalized statement like:

To install RHN Proxy Server from RHN Satellite Server, the Satellite itself must be version greater than or equal to the version of the Proxy you are trying to install.  For example, if you want to install RHN Proxy Server 5.1, the Satellite version could be 5.1, 5.2, 6.0, etc. but could not be 5.0, 4.2, etc.

or something like this.

== https://rlx-3-14.rhndev.redhat.com/rhn/help//satellite/en-US/s1-sync-iss.jsp ==
=== 6.4. Inter-Satellite Sync ===
# RHN Satellite 5.3.1 supports synchronization between two Satellites.
and
# At least two RHN Satellite 5.3.1 servers 
and
# If you are not sure if the Inter-Satellite Sync feature is right for your organization, please note that you can continue to use RHN Satellite 5.3.1 in the typical manner. Installing or upgrading to RHN Satellite 5.3.1 does not require that you make use of this feature. 

I believe in all four cases, the "5.3.1" should be replaced with "5.3 or greater"

Comment 3 Brandon Perkins 2010-05-07 19:51:22 UTC
Verified with:

satellite-doc-indexes-5.3.24-1.el4sat
satellite-branding-5.3.0.28-1.el4sat
rhn-i18n-guides-5.3.0.16-1.el4sat

Comment 4 Brandon Perkins 2010-05-14 22:22:58 UTC
Release Pending.  Checked on rlx-3-10.rhndev.redhat.com with:

rhn-i18n-guides-5.3.0.16-1.el5sat
rhn-i18n-release-notes-5.3.0.8-1.el5sat
satellite-branding-5.3.0.28-1.el5sat
satellite-doc-indexes-5.3.24-1.el5sat

Comment 5 errata-xmlrpc 2010-05-17 12:52:33 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0413.html


Note You need to log in before you can comment on or make changes to this bug.