Bug 57093 - spec file needs manpage logic for rh 6.2 etc
Summary: spec file needs manpage logic for rh 6.2 etc
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libcap   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-04 18:17 UTC by Matthew Miller
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-09 18:45:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Miller 2001-12-04 18:17:35 UTC
Description of Problem:

spec file contains:

  perl -pi -e 's,^man_prefix=.*,man_prefix=\$\(prefix)/share,g' Make.Rules

to make the man pages get installed in /usr/share/man instead of /usr/man.
Then, later on, it uses the %{_mandir} in the files list, which of course
doesn't work, because that points to /usr/man. This needs to be reconciled
-- the patch line should use the proper mandir instead of always sticking
share in there.

Version-Release number of selected component (if applicable):

1.10-5

How Reproducible:

innately.

Steps to Reproduce:
1. build rpm on RH 6.2

Actual Results:
fails to build -- can't find man pages

Expected Results:
correct package generated with man pages in correct location

Additional Information:

Comment 1 Matthew Miller 2003-05-09 18:45:36 UTC
I think this one can be closed as "no one cares anymore".


Note You need to log in before you can comment on or make changes to this bug.