Bug 570947 - knetworkmanager will not connect to wireless network
knetworkmanager will not connect to wireless network
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-plasma-networkmanagement (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-05 17:31 EST by Peter Gückel
Modified: 2010-10-09 14:28 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-09 14:28:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages snippet (11.47 KB, text/plain)
2010-03-07 23:23 EST, Peter Gückel
no flags Details

  None (edit)
Description Peter Gückel 2010-03-05 17:31:14 EST
Description of problem:
On my laptop (i686/PAE), knetworkmanager registers the powerfu l ignal my wireless network, but does not connect.

Version-Release number of selected component (if applicable):
0.9-0.12.20100220.fc13

How reproducible:
Set up a new wireless connection, enter all the information on the first and second tabs, leave the third tab with automatic dhcp and... nothing! My network shows up with signal strength of 99% and a large beacon indicator to the left, but no connection.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
As I have entered all of the information, including the code of my network, it should simply connect without further ado, just like it does when the wired cable is plugged in.

Additional info:
with f12 and gnome-networkmanager, this worked, but I had to enter a (nuisance) password for it to connect.
Comment 1 Peter Gückel 2010-03-05 17:33:39 EST
I would like to change the severity to urgent (I forgot to choose), as this problem makes the wireless totally unusable, which is definitely a BIG deal on a laptop.
Comment 2 Kevin Kofler 2010-03-05 18:44:51 EST
(FYI, knetworkmanager is built from the kde-plasma-networkmanagement SRPM because the stuff is all in the same upstream SVN directory, that's why the bug got reassigned. But knetworkmanager is the version we install by default and the one which SHOULD work.)

I'm putting this on the F13 KDE tracker.
Comment 3 Kevin Kofler 2010-03-05 18:52:52 EST
What's the exact type of encryption you use? (It's clearly not none as otherwise the GNOME nm-applet wouldn't need to unlock the keyring.) WEP? WPA1-PSK? WPA2-PSK? Some enterprise (802.1X, WPA-EAP etc.) setup? If it's WPA, do you use the secure CCMP/AES encryption or the legacy TKIP one? What wireless standard are you using? 802.11b? 802.11g? 802.11a? 802.11n on the b/g frequency (~2.4 GHz)? 802.11n on the a frequency (~4 GHz)?

And have you checked the logfiles for any interesting information?

Unfortunately, with no further information than "it doesn't connect to my wireless network", there's not much we can do. All I know is that knetworkmanager-0.9-0.12.20100220.fc12 (i.e. the exact same snapshot, but on F12) works for me with at least one WPA-PSK and at least two WPA-EAP networks, so it isn't completely broken. Therefore, there must be something about your setup it doesn't like and we urgently need to figure out what.
Comment 4 Peter Gückel 2010-03-06 14:31:21 EST
I'm not on my laptop right now, so I will get more information later. Where would I look for knetworkmanager logfiles?

I use a wireless router provided by my ISP, the 2WIRE 2700HG-E GATEWAY. I configure it using a web inferface.

Here is what I see using the web interface:

WPA-PSK (that must be WPA1-PSK; WEP-OPEN and WEP-SHARED are also available)
TKIP encryption (no other options available; I am using a custom encryption key that I select)
802.11b/g (manufacturer recommends this; one can also specifically choose 802.11b or 802.11g)
SSID broadcast enabled (I choose a network name of my choice)
DTIM period: 1 second (manufacturer recommends keeping this setting)
Access Point is shown (12-digit hex number; I entered this in the knetworkmanager configuration)
Comment 5 Peter Gückel 2010-03-06 14:45:20 EST
I just booted the laptop. All the information I had entered yesterday into the wireless network configuration is gone! It's empty. I have to fill in all the information all over again.

I will see if I can locate the log file and see what happens in a couple of minutes.
Comment 6 Peter Gückel 2010-03-06 14:49:52 EST
What am I supposed to choose in the knetworkmanager wireless configuration:

Infrastructure or Ad-Hoc?
Restrict to interface: Any or 802.11?
MTU: Automatic?

And on the IP Address tab, I didn't change anything, just left Automatic (DHCP). I don't enter anything there do I? No DHCP Client ID? I don't know what it would be.
Comment 7 Peter Gückel 2010-03-06 14:53:43 EST
Sorry, no it wasn't empty :-) I clicked new by accident, but the question in the previous comment still perturb me.

I'm looking in /var/log/* and there is no knetworkmanager log file.
Comment 8 Kevin Kofler 2010-03-06 15:39:38 EST
Your configuration is very standard, it's not normal at all that it isn't working.

Infrastructure is the one to pick, Any should be fine for "Restrict to interface", and MTU Automatic is also fine. Basically all at defaults, there's nothing strange about your setup.
Comment 9 Peter Gückel 2010-03-06 20:30:25 EST
As an experiment, I tried it as root, and it still didn't work. The broadcasting network icon is shown and the network name is shown, but there is no connection and clicking on this does not cause it to do so -- the same as when logged in as me.
Comment 10 Kevin Kofler 2010-03-07 19:24:14 EST
Is there anything interesting in /var/log/messages?
Comment 11 Peter Gückel 2010-03-07 23:23:04 EST
Created attachment 398424 [details]
/var/log/messages snippet

Yes, I think there might be something interesting here.
Comment 12 Peter Gückel 2010-03-07 23:24:21 EST
I hope you can find something.
Comment 13 Peter Gückel 2010-03-10 20:26:05 EST
As per some discussion on the kde mailing list, I installed both cnetworkmanager and NetworkManager-gnome. I killed knetworkmanager and tried first cnetworkmanager, then nm-applet, to no avail.
Comment 14 Kevin Kofler 2010-03-10 20:37:46 EST
Then it looks like your problem is not a KDE/knetworkmanager problem, but a problem with the networking stack on F13, either NetworkManager or even deeper.
Comment 15 Peter Gückel 2010-03-11 11:14:05 EST
I installed directly from the kde-live cd for f13α_rciv. That means there's something not right on the cd.

How does it get fixed?
Comment 16 Kevin Kofler 2010-03-11 12:01:49 EST
I'm fairly sure your issue is hardware-dependent. The GNOME nm-applet definitely works for most people (and it doesn't for you), and AFAIK knetworkmanager also works fine for most people (though we'd like to see more testing).
Comment 17 Peter Gückel 2010-03-11 17:16:54 EST
I haven't changed my hardware.

It was working fine in f12 and in f11 and earlier, so how could it be hardware-dependent now!?
Comment 18 Kevin Kofler 2010-03-11 17:22:23 EST
Maybe it's a regression in the driver for your hardware? Or a regression in NetworkManager which only hits some hardware?

It can't be knetworkmanager's fault because nm_applet is also not working for you.
Comment 19 Peter Gückel 2010-04-10 19:44:25 EDT
News flash!

I just installed the latest NetworkManager-0.8.0-6.git20100408.fc13.i686.

I am able to get a connection with cnetworkmanager! There is no driver hardware regression. The problem is knetworkmanager.
Comment 20 Kevin Kofler 2010-04-10 20:01:27 EDT
> I am able to get a connection with cnetworkmanager!

Now. Not before. Looks like you had at least 2 problems, which was confusing things. :-(
Comment 21 Peter Gückel 2010-04-11 15:05:34 EDT
(In reply to comment #20)
> > I am able to get a connection with cnetworkmanager!
> 
> Now. Not before.

Well, I cannot say for certain about how it was before. I had been overwhelmed with trying nm-applet and then cnetworkmanager, which I didn't understand (some programs call it SSID and others BSSID, no consistency, for example), and I had already rebooted a number of times by then, so I might not have rebooted and I was frustrated and the documentation for cnetworkmanager didn't seem clear to me then.

Last night, after upgrading to the new NetworkManager (and also discovering nm-tool, which gave me renewed hope, as it indicated that NetworkManager was seeing my network after all), I decided to give cnetworkmanager another try, after knetworkmanager had failed, and it worked.
Comment 22 Peter Gückel 2010-05-06 21:32:49 EDT
After updating to NetworkManager-0.8.0-12.git20100504, I was no longer able to get even cnetworkmanager to connect, which had been my failsafe, so I started to experiment.

I wish someone had told me not to use hexadecimal digits in the wpa password for wireless internet! Using only decimal digits (I could swear that I tried that weeks ago, to no avail), but tonight it seems to have done the trick.

I think this bug is solved. It works with knetworkmanager and nm-applet. I didn't bother trying cnetworkmanager.
Comment 23 Kevin Kofler 2010-05-09 10:59:28 EDT
Uh, if hex digits (A-F) don't work, that's a bug.
Comment 24 Peter Gückel 2010-05-09 12:44:18 EDT
(In reply to comment #23)
> Uh, if hex digits (A-F) don't work, that's a bug.    

I realize that.

I was thinking that when I enter the password containing a-f into my router, perhaps it doesn't encode it into the same thing that wpa_supplicant in Fedora encodes it to. Is that possible? I have no way to see the generated encoded string, only the original I typed in.
Comment 25 Peter Gückel 2010-06-05 20:52:49 EDT
I upraded to kde-4.80 and now I am unable to establish a wireless connection with knetworkmanager. I have a wpa password without hex digits (what worked before). Curiously, after updating kde, all of the knetworkmanager stuff was voided and I had to manually re-enter the bssid and password.
Comment 26 Piotrek Juźwiak 2010-07-17 07:15:25 EDT
I'd like to point out that restricting interface to only wireless makes it impossible to connect to a wireless network!! I have a WPA2 PSK wireless network with MAC address restrictions. If i set my connection restrictions to wireless instead of Any IT WILL NOT CONNECT no matter how many will i click my connection to reconnect BUT if i set it to Any it will connect with no problems at all!
Comment 27 Piotrek Juźwiak 2010-07-17 07:18:50 EDT
I guess the option to set interface restrictions is pretty hmm pointless? We can't set a WPA2 (or any other like WEP or WPA) to a wire connection? We can't set it to a MOBILE connection? This option should be made redundant and removed, it has no sense.
Comment 28 Peter Gückel 2010-07-17 14:56:20 EDT
These last comments have finally solved the problem for me here, I am reasonably confident :-)

Comment 26 states that restricting the interface makes the connection impossible. That got me thinking, hmmmm....

I checked and in the knetworkmanager configuration, I do not have the interface set to any specific interface (it is set to 'Any'), but I did have the BSSID set to the MAC address of my hardware.

I did a test connection to an unsecured network in my neighbourhood and it connected without fail. I compared this connection with my own wireless network and saw that the new connection does NOT have the BSSID entered in order to work. It only stated the SSID.

So, I changed my home wireless connection info in the knetworkmanager configuration to indicate the SSID (which is my network name), but leave the BSSID empty (this is the hardware MAC address or my wireless on my laptop) and keep 'restrict to interface' set at ANY. Then, I configured my router and it told me that TKIP must use a passpharase of at least 8 alphanumeric characters. I chose exactly 8, a mix of lower case, upper case and some numerals, and my alphbetic characters are not ones used by hexadecimal, ie, they are not a-f, A-F.

Et voilà! I not have wireless networking using knetworkmanager and I rebooted and it still works!

I really do think this is finally solved :-)

PS: I really find the BSSID and SSID terms used in knetworkmanager confusing. I don't know what the proper terms are. In knetworkmanager, SSID is the home network name, which my router calls SSID Broadcast. In knetworkmanager, BSSID is the MAC Address or hw-address of my wireless hardware in the laptop, but the router calls this my MAC address and never uses the term BSSID at all. This confusing naming threw me off for quite a while a few weeks ago when I first got onto this problem.
Comment 29 Fedora Admin XMLRPC Client 2010-09-11 19:52:07 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 30 Rex Dieter 2010-10-09 14:28:25 EDT
Per comment #28 , let's consider this resolved.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.