Bug 570977 - Deluge 1.3.1 is out
Summary: Deluge 1.3.1 is out
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: deluge
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rahul Sundaram
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 658470 661547 666988 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-06 02:26 UTC by sloan.moreau
Modified: 2011-03-28 08:58 UTC (History)
6 users (show)

Fixed In Version: deluge-1.3.1-2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-25 19:23:13 UTC


Attachments (Terms of Use)

Description sloan.moreau 2010-03-06 02:26:30 UTC
Description of problem: Deluge is out

This soft needs to be updated

Comment 1 Bug Zapper 2010-07-30 10:59:01 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Ankur Sinha (FranciscoD) 2010-12-27 15:42:58 UTC
(In reply to comment #0)
> Description of problem: Deluge is out
> 
> This soft needs to be updated

Hi, 

http://download.deluge-torrent.org/source/?C=M;O=D says that the latest is 1.3.1. Where did you come across 1.5.4? Please change the bug summary accordingly.

Thank You,
Ankur

Comment 3 Fabien Archambault 2011-03-04 14:35:52 UTC
Could it be possible to get a 1.3.1 version in F14 ?

Comment 4 Fedora Admin XMLRPC Client 2011-03-16 08:12:54 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 5 Rahul Sundaram 2011-03-16 15:46:03 UTC
*** Bug 658470 has been marked as a duplicate of this bug. ***

Comment 6 Rahul Sundaram 2011-03-16 15:46:41 UTC
*** Bug 661547 has been marked as a duplicate of this bug. ***

Comment 7 Rahul Sundaram 2011-03-16 15:46:56 UTC
*** Bug 666988 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2011-03-16 18:54:23 UTC
deluge-1.3.1-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/deluge-1.3.1-2.fc14

Comment 9 Fedora Update System 2011-03-25 19:22:34 UTC
deluge-1.3.1-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fabien Archambault 2011-03-27 23:27:25 UTC
Hi,

I was looking forward to this update but I cannot update.

I tried, with deluge installed: # yum clean all && yum update deluge\* --enablerepo=updates-testing
No Packages marked for Update

I tried to download all packages from: http://koji.fedoraproject.org/koji/buildinfo?buildID=234179
yum install /home/MarbolanGos/Downloads/deluge-*.rpm --nogpgcheck
Setting up Install Process
Examining /home/MarbolanGos/Downloads/deluge-1.3.1-2.fc14.noarch.rpm: deluge-1.3.1-2.fc14.noarch
/home/MarbolanGos/Downloads/deluge-1.3.1-2.fc14.noarch.rpm: does not update installed package.
Examining /home/MarbolanGos/Downloads/deluge-common-1.3.1-2.fc14.noarch.rpm: deluge-common-1.3.1-2.fc14.noarch
/home/MarbolanGos/Downloads/deluge-common-1.3.1-2.fc14.noarch.rpm: does not update installed package.
Examining /home/MarbolanGos/Downloads/deluge-console-1.3.1-2.fc14.noarch.rpm: deluge-console-1.3.1-2.fc14.noarch
/home/MarbolanGos/Downloads/deluge-console-1.3.1-2.fc14.noarch.rpm: does not update installed package.
Examining /home/MarbolanGos/Downloads/deluge-daemon-1.3.1-2.fc14.noarch.rpm: deluge-daemon-1.3.1-2.fc14.noarch
/home/MarbolanGos/Downloads/deluge-daemon-1.3.1-2.fc14.noarch.rpm: does not update installed package.
Examining /home/MarbolanGos/Downloads/deluge-gtk-1.3.1-2.fc14.noarch.rpm: deluge-gtk-1.3.1-2.fc14.noarch
/home/MarbolanGos/Downloads/deluge-gtk-1.3.1-2.fc14.noarch.rpm: does not update installed package.
Examining /home/MarbolanGos/Downloads/deluge-images-1.3.1-2.fc14.noarch.rpm: deluge-images-1.3.1-2.fc14.noarch
/home/MarbolanGos/Downloads/deluge-images-1.3.1-2.fc14.noarch.rpm: does not update installed package.
Examining /home/MarbolanGos/Downloads/deluge-web-1.3.1-2.fc14.noarch.rpm: deluge-web-1.3.1-2.fc14.noarch
/home/MarbolanGos/Downloads/deluge-web-1.3.1-2.fc14.noarch.rpm: does not update installed package.
Error: Nothing to do

So I removed deluge, then reinstall from koji rpms:
# yum remove deluge
# yum install /home/MarbolanGos/Downloads/deluge-*.rpm --nogpgcheck
Setting up Install Process
Examining /home/MarbolanGos/Downloads/deluge-1.3.1-2.fc14.noarch.rpm: deluge-1.3.1-2.fc14.noarch
Marking /home/MarbolanGos/Downloads/deluge-1.3.1-2.fc14.noarch.rpm to be installed
Examining /home/MarbolanGos/Downloads/deluge-common-1.3.1-2.fc14.noarch.rpm: deluge-common-1.3.1-2.fc14.noarch
/home/MarbolanGos/Downloads/deluge-common-1.3.1-2.fc14.noarch.rpm: does not update installed package.
Examining /home/MarbolanGos/Downloads/deluge-console-1.3.1-2.fc14.noarch.rpm: deluge-console-1.3.1-2.fc14.noarch
/home/MarbolanGos/Downloads/deluge-console-1.3.1-2.fc14.noarch.rpm: does not update installed package.
Examining /home/MarbolanGos/Downloads/deluge-daemon-1.3.1-2.fc14.noarch.rpm: deluge-daemon-1.3.1-2.fc14.noarch
/home/MarbolanGos/Downloads/deluge-daemon-1.3.1-2.fc14.noarch.rpm: does not update installed package.
Examining /home/MarbolanGos/Downloads/deluge-gtk-1.3.1-2.fc14.noarch.rpm: deluge-gtk-1.3.1-2.fc14.noarch
/home/MarbolanGos/Downloads/deluge-gtk-1.3.1-2.fc14.noarch.rpm: does not update installed package.
Examining /home/MarbolanGos/Downloads/deluge-images-1.3.1-2.fc14.noarch.rpm: deluge-images-1.3.1-2.fc14.noarch
/home/MarbolanGos/Downloads/deluge-images-1.3.1-2.fc14.noarch.rpm: does not update installed package.
Examining /home/MarbolanGos/Downloads/deluge-web-1.3.1-2.fc14.noarch.rpm: deluge-web-1.3.1-2.fc14.noarch
/home/MarbolanGos/Downloads/deluge-web-1.3.1-2.fc14.noarch.rpm: does not update installed package.
Resolving Dependencies
--> Running transaction check
---> Package deluge.noarch 0:1.3.1-2.fc14 set to be installed
--> Processing Dependency: deluge-common = 1.3.1-2.fc14 for package: deluge-1.3.1-2.fc14.noarch
--> Processing Dependency: deluge-gtk = 1.3.1-2.fc14 for package: deluge-1.3.1-2.fc14.noarch
--> Processing Dependency: deluge-images = 1.3.1-2.fc14 for package: deluge-1.3.1-2.fc14.noarch
--> Processing Dependency: deluge-console = 1.3.1-2.fc14 for package: deluge-1.3.1-2.fc14.noarch
--> Processing Dependency: deluge-web = 1.3.1-2.fc14 for package: deluge-1.3.1-2.fc14.noarch
--> Processing Dependency: deluge-daemon = 1.3.1-2.fc14 for package: deluge-1.3.1-2.fc14.noarch
--> Finished Dependency Resolution
Error: Package: deluge-1.3.1-2.fc14.noarch (/deluge-1.3.1-2.fc14.noarch)
           Requires: deluge-common = 1.3.1-2.fc14
           Installed: deluge-common-1.3.1-4.fc14.noarch (@/deluge-common-1.3.1-4.fc14.noarch)
               deluge-common = 1.3.1-4.fc14
           Available: deluge-common-1.3.1-2.fc14.noarch (updates)
               deluge-common = 1.3.1-2.fc14
Error: Package: deluge-1.3.1-2.fc14.noarch (/deluge-1.3.1-2.fc14.noarch)
           Requires: deluge-console = 1.3.1-2.fc14
           Installed: deluge-console-1.3.1-4.fc14.noarch (@/deluge-console-1.3.1-4.fc14.noarch)
               deluge-console = 1.3.1-4.fc14
           Available: deluge-console-1.3.1-2.fc14.noarch (updates)
               deluge-console = 1.3.1-2.fc14
Error: Package: deluge-1.3.1-2.fc14.noarch (/deluge-1.3.1-2.fc14.noarch)
           Requires: deluge-daemon = 1.3.1-2.fc14
           Installed: deluge-daemon-1.3.1-4.fc14.noarch (@/deluge-daemon-1.3.1-4.fc14.noarch)
               deluge-daemon = 1.3.1-4.fc14
           Available: deluge-daemon-1.3.1-2.fc14.noarch (updates)
               deluge-daemon = 1.3.1-2.fc14
Error: Package: deluge-1.3.1-2.fc14.noarch (/deluge-1.3.1-2.fc14.noarch)
           Requires: deluge-images = 1.3.1-2.fc14
           Installed: deluge-images-1.3.1-4.fc14.noarch (@/deluge-images-1.3.1-4.fc14.noarch)
               deluge-images = 1.3.1-4.fc14
           Available: deluge-images-1.3.1-2.fc14.noarch (updates)
               deluge-images = 1.3.1-2.fc14
Error: Package: deluge-1.3.1-2.fc14.noarch (/deluge-1.3.1-2.fc14.noarch)
           Requires: deluge-gtk = 1.3.1-2.fc14
           Installed: deluge-gtk-1.3.1-4.fc14.noarch (@/deluge-gtk-1.3.1-4.fc14.noarch)
               deluge-gtk = 1.3.1-4.fc14
           Available: deluge-gtk-1.3.1-2.fc14.noarch (updates)
               deluge-gtk = 1.3.1-2.fc14
Error: Package: deluge-1.3.1-2.fc14.noarch (/deluge-1.3.1-2.fc14.noarch)
           Requires: deluge-web = 1.3.1-2.fc14
           Installed: deluge-web-1.3.1-4.fc14.noarch (@/deluge-web-1.3.1-4.fc14.noarch)
               deluge-web = 1.3.1-4.fc14
           Available: deluge-web-1.3.1-2.fc14.noarch (updates)
               deluge-web = 1.3.1-2.fc14
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Also tried using repos:
# yum install deluge --enablerepo=updates-testing
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package deluge.noarch 0:1.3.1-2.fc14 set to be installed
--> Processing Dependency: deluge-images = 1.3.1-2.fc14 for package: deluge-1.3.1-2.fc14.noarch
--> Processing Dependency: deluge-gtk = 1.3.1-2.fc14 for package: deluge-1.3.1-2.fc14.noarch
--> Processing Dependency: deluge-web = 1.3.1-2.fc14 for package: deluge-1.3.1-2.fc14.noarch
--> Processing Dependency: deluge-daemon = 1.3.1-2.fc14 for package: deluge-1.3.1-2.fc14.noarch
--> Processing Dependency: deluge-console = 1.3.1-2.fc14 for package: deluge-1.3.1-2.fc14.noarch
--> Processing Dependency: deluge-common = 1.3.1-2.fc14 for package: deluge-1.3.1-2.fc14.noarch
--> Finished Dependency Resolution
Error: Package: deluge-1.3.1-2.fc14.noarch (updates)
           Requires: deluge-console = 1.3.1-2.fc14
           Installed: deluge-console-1.3.1-4.fc14.noarch (@/deluge-console-1.3.1-4.fc14.noarch)
               deluge-console = 1.3.1-4.fc14
           Available: deluge-console-1.3.1-2.fc14.noarch (updates)
               deluge-console = 1.3.1-2.fc14
Error: Package: deluge-1.3.1-2.fc14.noarch (updates)
           Requires: deluge-common = 1.3.1-2.fc14
           Installed: deluge-common-1.3.1-4.fc14.noarch (@/deluge-common-1.3.1-4.fc14.noarch)
               deluge-common = 1.3.1-4.fc14
           Available: deluge-common-1.3.1-2.fc14.noarch (updates)
               deluge-common = 1.3.1-2.fc14
Error: Package: deluge-1.3.1-2.fc14.noarch (updates)
           Requires: deluge-daemon = 1.3.1-2.fc14
           Installed: deluge-daemon-1.3.1-4.fc14.noarch (@/deluge-daemon-1.3.1-4.fc14.noarch)
               deluge-daemon = 1.3.1-4.fc14
           Available: deluge-daemon-1.3.1-2.fc14.noarch (updates)
               deluge-daemon = 1.3.1-2.fc14
Error: Package: deluge-1.3.1-2.fc14.noarch (updates)
           Requires: deluge-web = 1.3.1-2.fc14
           Installed: deluge-web-1.3.1-4.fc14.noarch (@/deluge-web-1.3.1-4.fc14.noarch)
               deluge-web = 1.3.1-4.fc14
           Available: deluge-web-1.3.1-2.fc14.noarch (updates)
               deluge-web = 1.3.1-2.fc14
Error: Package: deluge-1.3.1-2.fc14.noarch (updates)
           Requires: deluge-gtk = 1.3.1-2.fc14
           Installed: deluge-gtk-1.3.1-4.fc14.noarch (@/deluge-gtk-1.3.1-4.fc14.noarch)
               deluge-gtk = 1.3.1-4.fc14
           Available: deluge-gtk-1.3.1-2.fc14.noarch (updates)
               deluge-gtk = 1.3.1-2.fc14
Error: Package: deluge-1.3.1-2.fc14.noarch (updates)
           Requires: deluge-images = 1.3.1-2.fc14
           Installed: deluge-images-1.3.1-4.fc14.noarch (@/deluge-images-1.3.1-4.fc14.noarch)
               deluge-images = 1.3.1-4.fc14
           Available: deluge-images-1.3.1-2.fc14.noarch (updates)
               deluge-images = 1.3.1-2.fc14
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


It seems I have a dependency failure but where?

Comment 11 Rahul Sundaram 2011-03-27 23:58:57 UTC
You seem to have been using some self rebuild packages.  yum remove deluge-common 

rpm -qa | grep -i deluge  to make sure you don't have any deluge packages leftover and try again with  

rpm -Uvh deluge*.rpm  or  yum install deluge --enablerepo=updates-testing

Comment 12 Fabien Archambault 2011-03-28 08:33:51 UTC
Thanks it worked. I completely forgot I had recompiled the SRPM from F15 in order to get the latest version...

Comment 13 Rahul Sundaram 2011-03-28 08:58:55 UTC
Then you might as well as have left it as it is.  The version is pushed as an update was basically the same.


Note You need to log in before you can comment on or make changes to this bug.