Bug 571039 - default cursor theme tries to inherit Bluecurve which is not installed by default
default cursor theme tries to inherit Bluecurve which is not installed by def...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libXcursor (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
: 570159 (view as bug list)
Depends On:
Blocks: F13blocker-KDE
  Show dependency treegraph
 
Reported: 2010-03-06 10:17 EST by nucleo
Modified: 2014-06-18 05:12 EDT (History)
13 users (show)

See Also:
Fixed In Version: libXcursor-1.1.10-4.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-19 23:47:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nucleo 2010-03-06 10:17:50 EST
Description of problem:
On nightly-composes LiveCD kde-i386-20100305.18.iso by default used old KDE Classic(KDE2) cursor theme. There are also installed dmz and dmz-aa.
May be dmz-aa should be used as default instead of KDE Classic.
Comment 1 Kevin Kofler 2010-03-06 10:46:14 EST
*** Bug 570159 has been marked as a duplicate of this bug. ***
Comment 2 Kevin Kofler 2010-03-06 11:11:20 EST
This is because KDE is set up to use the "default" cursor theme, which is not set up properly in F13.

libXcursor ships a /usr/share/icons/default which is supposed to inherit the default cursor theme. It currently Inherits=Bluecurve, but bluecurve-cursor-theme is no longer installed by default (dmz-cursor-theme is).
Comment 3 Rex Dieter 2010-03-08 14:44:24 EST
So, can we expect libXcursor to grow the proper dependency on it's default cursor theme (and "just work"), or are DE's expected to do their own thing?
Comment 4 Matthias Clasen 2010-03-08 16:41:51 EST
Sorry, I had forgotten about this 'default' thing, since we are no longer using it on the gnome side. If you still rely on it, we should fix it.
Comment 5 Matthias Clasen 2010-03-08 16:48:12 EST
second question is: do you want to use dmz cursors ? I want to try them out in the gnome spin, but I don't want to force them on you.
Comment 6 Jaroslav Reznik 2010-03-09 07:49:13 EST
Hi Matthias,
I'm adding it as topic to our weekly KDE SIG meeting agenda. Not sure about clean DMZ but DMZ AA looks very nice.
Comment 7 Rex Dieter 2010-03-09 10:20:31 EST
we just met, and agreed to try out dmz (or dmz-aa) too.

So, implement that here then?
Comment 8 Fedora Update System 2010-03-09 10:35:43 EST
libXcursor-1.1.10-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libXcursor-1.1.10-4.fc13
Comment 9 Fedora Update System 2010-03-11 02:24:40 EST
libXcursor-1.1.10-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libXcursor'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libXcursor-1.1.10-4.fc13
Comment 10 Fedora Update System 2010-03-19 23:47:06 EDT
libXcursor-1.1.10-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Nickolay Bunev 2010-04-27 15:43:30 EDT
I made a comment earlier today - https://bugzilla.redhat.com/show_bug.cgi?id=581173 about an issue that seems to be related to this. After upgrade from F12 to F13 via yum I can't change the cursor theme in System settings. As I stated in the other bug I replaced dmz-aa with Bluecurve in /etc/gtk-2.0/gtkrc and it seems to do the trick, but where is the right place/file to do this?

Note You need to log in before you can comment on or make changes to this bug.