Bug 571050 - KMS:Juniper PRO:Radeon HD 5750 refresh rate only 60 Hz on analog monitor
Summary: KMS:Juniper PRO:Radeon HD 5750 refresh rate only 60 Hz on analog monitor
Keywords:
Status: CLOSED DUPLICATE of bug 536686
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jérôme Glisse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-06 16:42 UTC by Eduard VANKO
Modified: 2018-04-11 18:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-09 14:09:32 UTC
Type: ---


Attachments (Terms of Use)
xorg.conf (863 bytes, text/plain)
2010-03-14 06:29 UTC, Eduard VANKO
no flags Details
dmesg (38.53 KB, text/plain)
2010-03-14 06:32 UTC, Eduard VANKO
no flags Details
/var/log/messages (50.55 KB, text/plain)
2010-03-14 06:37 UTC, Eduard VANKO
no flags Details
/var/log/Xorg.0.log (33.61 KB, text/plain)
2010-03-14 06:40 UTC, Eduard VANKO
no flags Details
dmesg without using of /etc/X11/xorg.conf (42.12 KB, text/plain)
2010-11-03 20:27 UTC, Eduard VANKO
no flags Details
/var/log/messages without using /etc/X11/xorg.conf (279.07 KB, text/plain)
2010-11-03 20:28 UTC, Eduard VANKO
no flags Details
xrand without using /etc/X11/xorg.conf (455 bytes, text/plain)
2010-11-03 20:29 UTC, Eduard VANKO
no flags Details
Xorg.0.log without using /etc/X11/xorg.conf (30.78 KB, text/plain)
2010-11-03 20:30 UTC, Eduard VANKO
no flags Details

Description Eduard VANKO 2010-03-06 16:42:56 UTC
Description of problem:
refresh rate only 60 Hz on radeon HD5750 & analog monitor, 85Hz refresh rate only with vesa driver

Version-Release number of selected component (if applicable):
Fedora 12 x86_64
kernel 2.6.32.9-67.fc12.x86_64
xorg-x11-server-Xorg-1.7.5-5.fc12.x86_64
xorg-x11-drv-ati-6.13.0-0.21.20100219gite68d3a389.fc12.x86_64
Eizo Flexscan T560i-T analog monitor (no DDC) connected via DVI to VGA reduction

How reproducible:


Steps to Reproduce:
1. start Xorg
2. run xrandr
3.
  
Actual results:
1024x768/60Hz resolution

Expected results:
1024x768/85Hz resolution

Additional info:

part of xorg.conf:
Section "Monitor"
        Identifier   "Monitor0"
        ModelName    "Eizo FlexScan T560i"
        HorizSync    30.0 - 82.0
        VertRefresh  55.0 - 90.0
        Option      "dpms"
EndSection
Section "Device"
        Identifier  "Videocard0"
        Driver      "radeon"
EndSectionSection "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

xrandr:Screen 0: minimum 320 x 200, current 1024 x 768, maximum 2944 x 1024
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-1 disconnected (normal left inverted right x axis y axis)
DVI-0 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       59.9*+
   800x600        59.9  
   640x480        59.4  

have tried this:
xrandr --output DVI-0 --set dvi_monitor_type analog
but no change

Comment 1 Matěj Cepl 2010-03-12 00:17:11 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), output of the dmesg command, system log (/var/log/messages), and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Eduard VANKO 2010-03-14 06:29:31 UTC
Created attachment 399951 [details]
xorg.conf

Comment 3 Eduard VANKO 2010-03-14 06:32:51 UTC
Created attachment 399952 [details]
dmesg

Comment 4 Eduard VANKO 2010-03-14 06:37:27 UTC
Created attachment 399953 [details]
/var/log/messages

Comment 5 Eduard VANKO 2010-03-14 06:40:44 UTC
Created attachment 399954 [details]
/var/log/Xorg.0.log

Comment 6 Eduard VANKO 2010-03-14 06:44:58 UTC
Thanks for the reply, the requested files are attached. Kernel & Xorg server updated to the latest stable version, the problem still persists.

Comment 7 Reilly Hall 2010-03-15 13:21:22 UTC
I have a similar bug filed: https://bugzilla.redhat.com/show_bug.cgi?id=572578  could it be possible they are related?  Just wondering.

Comment 8 Vedran Miletić 2010-05-24 19:20:30 UTC
Improving summary.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

[This triage is part of collective effort done by students of University of
Rijeka Department of Informatics.]

Comment 9 Eduard VANKO 2010-09-04 15:07:29 UTC
The same problem in Fedora 13

Comment 10 Matěj Cepl 2010-11-01 18:09:11 UTC
Why do you have /etc/X11/xorg.conf at all? Is there something which doesn't work for you if you remove the file (or more likely move it somewhere very else)? If yes, could we get the logs from the test without /etc/X11/xorg.conf as well, please?

Thank you

Comment 11 Eduard VANKO 2010-11-03 20:27:29 UTC
Created attachment 457578 [details]
dmesg without using of /etc/X11/xorg.conf

Comment 12 Eduard VANKO 2010-11-03 20:28:53 UTC
Created attachment 457582 [details]
/var/log/messages without using /etc/X11/xorg.conf

Comment 13 Eduard VANKO 2010-11-03 20:29:49 UTC
Created attachment 457583 [details]
xrand without using /etc/X11/xorg.conf

Comment 14 Eduard VANKO 2010-11-03 20:30:35 UTC
Created attachment 457584 [details]
Xorg.0.log without using /etc/X11/xorg.conf

Comment 15 Eduard VANKO 2010-11-03 20:39:13 UTC
The reason of using /etc/X11/xorg.conf:
Newer displays have DDC/EDID, via which driver can detect supported resolutions, refresh rates. I have old (bud good) monitor, which don't have DDC/EDID, driver don't detect all available resolutions & refresh rates. In this case, there is a chance to force resolutions & refresh rates via /etc/X11/xorg.conf - from unknown reason, this is not functional...

Comment 16 Adam Pribyl 2010-11-07 08:54:19 UTC
This is a general problem of ati radeon driver. Please see also bug 536686. IMHO This one may be closed as duplicate.

Comment 17 Matěj Cepl 2010-11-09 14:09:32 UTC
(In reply to comment #16)
> This is a general problem of ati radeon driver. Please see also bug 536686.
> IMHO This one may be closed as duplicate.

Right you are.

*** This bug has been marked as a duplicate of bug 536686 ***


Note You need to log in before you can comment on or make changes to this bug.